Improper input validation in HackerOne defaults-deep node module
Priority MEDIUM 42CWE-471Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
defaults-deep node module before 0.2.4 suffers from a Modification of Assumed-Immutable Data (MAID) vulnerability, which allows a malicious user to modify the prototype of "Object" via __proto__, causing the addition or modification of an existing property that will exist on all objects.
Why it matters now
EPSS 0.02004 80th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed defaults-deep node module (HackerOne): 0.2.4defaults-deep (npm): 0.2.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | defaults-deep node module | before 0.2.4 | 0.2.4 | Patch available | CNA |
| — | defaults-deep (npm) | before 0.2.4 | 0.2.4 | Patch available | GHSA-cqp5-m4pq-gfgp |
- defaults-deep node module VendorHackerOne Affected before 0.2.4 Fixed in 0.2.4 Patch available CNA
- defaults-deep (npm) Vendor— Affected before 0.2.4 Fixed in 0.2.4 Patch available GHSA-cqp5-m4pq-gfgp
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:defaults-deep_project:defaults-deep:*:*:*:*:*:node.js:*:* | before 0.2.4 | Vulnerable | Defaults-deep Project |
- cpe:2.3:a:defaults-deep_project:defaults-deep:*:*:*:*:*:node.js:*:* Versions before 0.2.4 Vulnerable ·Defaults-deep Project
Remediation
- Fix · CNA defaults-deep node module (HackerOne) Fixed in 0.2.4
- Fix · GHSA-cqp5-m4pq-gfgp defaults-deep (npm) Fixed in 0.2.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-3723
- 2026-10-03 Alias added: GHSA-cqp5-m4pq-gfgp
References
More Defaults-deep Project Defaults-deep vulnerabilities
- TI-2018-11828 Uncontrolled resource consumption in HackerOne defaults-deep CVSS 3.0CRITICAL 9.8
Sources
- CVE-2018-3723 · CVE Program
- CVE-2018-3723 · NVD
- FIRST EPSS
- GHSA-cqp5-m4pq-gfgp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences