ruby-grape ruby gem suffers from a cross-site scripting (XSS) vulnerability via "format" parameter.
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
ruby-grape ruby gem suffers from a cross-site scripting (XSS) vulnerability via "format" parameter.
Why it matters now
EPSS 0.01428 73rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed grape (RubyGems): 1.1.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Ruby Grape | ruby-grape ruby gem | >= 1.0.3 | — | No fix listed | CNA |
| — | grape (RubyGems) | before 1.1.0 | 1.1.0 | Patch available | GHSA-f599-5m7p-hcpf |
- ruby-grape ruby gem VendorRuby Grape Affected >= 1.0.3 Fixed in — No fix listed CNA
- grape (RubyGems) Vendor— Affected before 1.1.0 Fixed in 1.1.0 Patch available GHSA-f599-5m7p-hcpf
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ruby-grape:grape:*:*:*:*:*:*:*:* | up to 1.0.3 | Vulnerable | Ruby Grape |
- cpe:2.3:a:ruby-grape:grape:*:*:*:*:*:*:*:* Versions up to 1.0.3 Vulnerable ·Ruby Grape
Remediation
- Fix · GHSA-f599-5m7p-hcpf grape (RubyGems) Fixed in 1.1.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-3769
- 2026-10-03 Alias added: GHSA-f599-5m7p-hcpf
References
Advisory 2
Sources
- CVE-2018-3769 · CVE Program
- CVE-2018-3769 · NVD
- FIRST EPSS
- GHSA-f599-5m7p-hcpf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences