Improper input validation in https://github.com/restforce restforce ruby gem
Priority MEDIUM 45CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Insufficient URI encoding in restforce before 3.0.0 allows attacker to inject arbitrary parameters into Salesforce API requests.
Why it matters now
EPSS 0.01506 74th percentileScored 2026-11-07
Fix Fixed restforce (RubyGems): 3.0.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| https://github.com/restforce | restforce ruby gem | 3.0.0 | — | No fix listed | CNA |
| — | restforce (RubyGems) | before 3.0.0 | 3.0.0 | Patch available | GHSA-534w-937m-v7x3 |
- restforce ruby gem Vendorhttps://github.com/restforce Affected 3.0.0 Fixed in — No fix listed CNA
- restforce (RubyGems) Vendor— Affected before 3.0.0 Fixed in 3.0.0 Patch available GHSA-534w-937m-v7x3
Remediation
- Fix · GHSA-534w-937m-v7x3 restforce (RubyGems) Fixed in 3.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-3777
- 2026-10-03 Alias added: GHSA-534w-937m-v7x3
References
Sources
- CVE-2018-3777 · CVE Program
- CVE-2018-3777 · NVD
- FIRST EPSS
- GHSA-534w-937m-v7x3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences