Cross-site scripting in Elasticsearch X-Pack Machine Learning
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
X-Pack Machine Learning versions before 6.2.4 and 5.6.9 had a cross-site scripting (XSS) vulnerability. If an attacker is able to inject data into an index that has a ML job running against it, then when another user views the results of the ML job it could allow the attacker to obtain sensitive information from or perform destructive actions on behalf of that other ML user.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Elastic | Elasticsearch X-Pack Machine Learning | before 6.2.4 and 5.6.9 | — | No fix listed | CNA |
| — | org.elasticsearch:elasticsearch (Maven) | before 5.6.9 | 5.6.9 | Patch available | GHSA-mjpc-qx7h-r8c9 |
| — | org.elasticsearch:elasticsearch (Maven) | 6.0.0 to before 6.2.4 | 6.2.4 | Patch available | GHSA-mjpc-qx7h-r8c9 |
- Elasticsearch X-Pack Machine Learning VendorElastic Affected before 6.2.4 and 5.6.9 Fixed in — No fix listed CNA
- org.elasticsearch:elasticsearch (Maven) Vendor— Affected before 5.6.9 Fixed in 5.6.9 Patch available GHSA-mjpc-qx7h-r8c9
- org.elasticsearch:elasticsearch (Maven) Vendor— Affected 6.0.0 to before 6.2.4 Fixed in 6.2.4 Patch available GHSA-mjpc-qx7h-r8c9
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:elastic:elasticsearch_x-pack:*:*:*:*:*:*:*:* | before 5.6.9; 6.0.0 to before 6.2.4 | Vulnerable | Elastic |
| cpe:2.3:a:elastic:kibana_x-pack:*:*:*:*:*:*:*:* | before 5.6.9; 6.0.0 to before 6.2.4 | Vulnerable | Elastic |
| cpe:2.3:a:elastic:logstash_x-pack:*:*:*:*:*:*:*:* | before 5.6.9; 6.1.0 to before 6.2.4 | Vulnerable | Elastic |
- cpe:2.3:a:elastic:elasticsearch_x-pack:*:*:*:*:*:*:*:* Versions before 5.6.9; 6.0.0 to before 6.2.4 Vulnerable ·Elastic
- cpe:2.3:a:elastic:kibana_x-pack:*:*:*:*:*:*:*:* Versions before 5.6.9; 6.0.0 to before 6.2.4 Vulnerable ·Elastic
- cpe:2.3:a:elastic:logstash_x-pack:*:*:*:*:*:*:*:* Versions before 5.6.9; 6.1.0 to before 6.2.4 Vulnerable ·Elastic
Remediation
- Fix · GHSA-mjpc-qx7h-r8c9 org.elasticsearch:elasticsearch (Maven) Fixed in 5.6.9 Advisory →
- Fix · GHSA-mjpc-qx7h-r8c9 org.elasticsearch:elasticsearch (Maven) Fixed in 6.2.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-3824
- 2026-10-03 Alias added: GHSA-mjpc-qx7h-r8c9
References
More Elasticsearch X-pack vulnerabilities
- TI-2018-02793 Cross-site scripting in Elasticsearch X-Pack Machine Learning CVSS 3.1MEDIUM 5.4
Sources
- CVE-2018-3824 · CVE Program
- CVE-2018-3824 · NVD
- FIRST EPSS
- GHSA-mjpc-qx7h-r8c9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences