In OpenCV 3.3.1, a heap-based buffer overflow happens in…
Priority LOW 28CWE-787Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-787 and the CVSS impact.
Summary
In OpenCV 3.3.1, a heap-based buffer overflow happens in cv::Jpeg2KDecoder::readComponent8u in modules/imgcodecs/src/grfmt_jpeg2000.cpp when parsing a crafted image file.
Why it matters now
EPSS 0.01519 74th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial opencv-python (PyPI): 3.4.1.15opencv-contrib-python (PyPI): 3.4.1.15Red Hat: 3 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | opencv-python (PyPI) | before 3.4.1.15 | 3.4.1.15 | Patch available | GHSA-9g8h-pjm4-q92p |
| — | opencv-contrib-python (PyPI) | before 3.4.1.15 | 3.4.1.15 | Patch available | GHSA-9g8h-pjm4-q92p |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- opencv-python (PyPI) Vendor— Affected before 3.4.1.15 Fixed in 3.4.1.15 Patch available GHSA-9g8h-pjm4-q92p
- opencv-contrib-python (PyPI) Vendor— Affected before 3.4.1.15 Fixed in 3.4.1.15 Patch available GHSA-9g8h-pjm4-q92p
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:opencv:opencv:3.3.1:*:*:*:*:*:*:* | 3.3.1 | Vulnerable | OpenCV |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:opencv:opencv:3.3.1:*:*:*:*:*:*:* Versions 3.3.1 Vulnerable ·OpenCV
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-9g8h-pjm4-q92p opencv-python (PyPI) Fixed in 3.4.1.15 Advisory →
- Fix · GHSA-9g8h-pjm4-q92p opencv-contrib-python (PyPI) Fixed in 3.4.1.15 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2018-5268
- 2026-10-03 Alias added: GHSA-9g8h-pjm4-q92p
References
Advisory 4
Sources
- CVE-2018-5268 · CVE Program
- CVE-2018-5268 · NVD
- FIRST EPSS
- GHSA-9g8h-pjm4-q92p · GitHub Advisory Database · CC BY 4.0
- CVE-2018-5268 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences