Infinite loop in Quagga bgpd
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-835.
Summary
The Quagga BGP daemon (bgpd) prior to version 1.2.3 has a bug in its parsing of "Capabilities" in BGP OPEN messages, in the bgp_packet.c:bgp_capability_msg_parse function. The parser can enter an infinite loop on invalid capabilities if a Multi-Protocol capability does not have a recognized AFI/SAFI, causing a denial of service.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Quagga | bgpd | bpgd to before 1.2.3 | 1.2.3 | Patch available | CNA |
- bgpd VendorQuagga Affected bpgd to before 1.2.3 Fixed in 1.2.3 Patch available CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:quagga:quagga:*:*:*:*:*:*:*:* | up to 1.2.2 | Vulnerable | Quagga |
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* | 16.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:17.10:*:*:*:*:*:*:* | 17.10 | Vulnerable | Canonical |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:siemens:ruggedcom_rox_ii_firmware:*:*:*:*:*:*:*:* | before 2.13.0 | Vulnerable | Siemens |
| cpe:2.3:h:siemens:ruggedcom_rox_ii:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Siemens |
- cpe:2.3:a:quagga:quagga:*:*:*:*:*:*:*:* Versions up to 1.2.2 Vulnerable ·Quagga
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* Versions 16.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:17.10:*:*:*:*:*:*:* Versions 17.10 Vulnerable ·Canonical
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:siemens:ruggedcom_rox_ii_firmware:*:*:*:*:*:*:*:* Versions before 2.13.0 Vulnerable ·Siemens
- cpe:2.3:h:siemens:ruggedcom_rox_ii:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Siemens
Remediation
- Fix · CNA bgpd (Quagga) Fixed in 1.2.3
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Quagga bgpd — GLSA-201804-17
4 records Highest priority Priority HIGH 2 HIGH, 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2018-03911 Memory corruption in Quagga bgpdPriority HIGH 70
- TI-2018-03912 Double free in Quagga bgpdPriority HIGH 69
- TI-2018-03913 Out-of-bounds read in Quagga bgpdPriority LOW 36
- Advisory ·
Quagga bgpd — USN-3573-1
4 records Highest priority Priority HIGH 2 HIGH, 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2018-03911 Memory corruption in Quagga bgpdPriority HIGH 70
- TI-2018-03912 Double free in Quagga bgpdPriority HIGH 69
- TI-2018-03913 Out-of-bounds read in Quagga bgpdPriority LOW 36
Show 1 more group
- Advisory ·
Quagga bgpd — DSA-4115
4 records Highest priority Priority HIGH 2 HIGH, 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2018-03911 Memory corruption in Quagga bgpdPriority HIGH 70
- TI-2018-03912 Double free in Quagga bgpdPriority HIGH 69
- TI-2018-03913 Out-of-bounds read in Quagga bgpdPriority LOW 36
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 5 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Will not fix |
Not affected: 1 product
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2018-5381
- 2026-10-03 Alias added: GHSA-g4qp-j7fc-2xcf
References
Advisory 8
- https://gogs.quagga.net/Quagga/quagga/src/master/doc/security/Quagga-2018-1975.txt
- USN-3573-1
- DSA-4115
- http://savannah.nongnu.org/forum/forum.php?forum_id=9095
- GLSA-201804-17
- [debian-lts-announce] 20180216 [SECURITY] [DLA 1286-1] quagga security update
- VU#940439
- https://cert-portal.siemens.com/productcert/pdf/ssa-451142.pdf
More Quagga vulnerabilities
- TI-2018-03911 Memory corruption in Quagga bgpd CVSS 3.0HIGH 7.1
- TI-2018-03912 Double free in Quagga bgpd CVSS 3.0CRITICAL 9.8
- TI-2017-11946 The aspath_put function in bgpd/bgp_aspath.c in Quagga before 1.2.2 allows remote… CVSS 3.0HIGH 7.5
- TI-2017-03515 All versions of Quagga, 0.93 through 1.1.0, are vulnerable to an unbounded memory… CVSS 3.0HIGH 7.5
- TI-2016-02105 The bgp_nlri_parse_vpnv4 function in bgp_mplsvpn.c in the VPNv4 NLRI parser in bgpd in… CVSS 3.0HIGH 8.1
- TI-2016-01143 Memory corruption in Quagga before 1.0.20161017 CVSS 3.0CRITICAL 9.8
Sources
- CVE-2018-5381 · CVE Program
- CVE-2018-5381 · NVD
- FIRST EPSS
- GHSA-g4qp-j7fc-2xcf · GitHub Advisory Database · CC BY 4.0
- CVE-2018-5381 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences