A specially crafted packet can cause named to leak memory
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-772.
Summary
A failure to free memory can occur when processing messages having a specific combination of EDNS options. Versions affected are: BIND 9.10.7 -> 9.10.8-P1, 9.11.3 -> 9.11.5-P1, 9.12.0 -> 9.12.3-P1, and versions 9.10.7-S1 -> 9.11.5-S3 of BIND 9 Supported Preview Edition. Versions 9.13.0 -> 9.13.6 of the 9.13 development branch are also affected.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ISC | BIND 9 | BIND 9.10.7 -> 9.10.8-P1, 9.11.3 -> 9.11.5-P1, 9.12.0 -> 9.12.3-P1, and versions 9.10.7-S1 -> 9.11.5-S3 of BIND 9 Supported Preview Edition. Versions 9.13.0 -> 9.13.6 of the 9.13 development branch are also affected. | — | No fix listed | CNA |
- BIND 9 VendorISC Affected BIND 9.10.7 -> 9.10.8-P1, 9.11.3 -> 9.11.5-P1, 9.12.0 -> 9.12.3-P1, and versions 9.10.7-S1 -> 9.11.5-S3 of BIND 9 Supported Preview Edition. Versions 9.13.0 -> 9.13.6 of the 9.13 development branch are also affected. Fixed in — No fix listed CNA
CPE configurations NVD · 13
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:* | 9.10.7 to before 9.10.8; 9.11.3 to before 9.11.5; 9.12.0 to before 9.12.3; 9.13.0 to before 9.13.6 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.7:s1:*:*:supported_preview:*:*:* | 9.10.7 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.8:-:*:*:*:*:*:* | 9.10.8 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.8:p1:*:*:*:*:*:* | 9.10.8 p1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.8:rc1:*:*:*:*:*:* | 9.10.8 rc1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.8:rc2:*:*:*:*:*:* | 9.10.8 rc2 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.11.5:-:*:*:*:*:*:* | 9.11.5 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.11.5:p1:*:*:*:*:*:* | 9.11.5 p1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.11.5:rc1:*:*:*:*:*:* | 9.11.5 rc1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.11.5:s3:*:*:supported_preview:*:*:* | 9.11.5 s3 | Vulnerable | ISC |
- cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:* Versions 9.10.7 to before 9.10.8; 9.11.3 to before 9.11.5; 9.12.0 to before 9.12.3; 9.13.0 to before 9.13.6 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.7:s1:*:*:supported_preview:*:*:* Versions 9.10.7 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.8:-:*:*:*:*:*:* Versions 9.10.8 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.8:p1:*:*:*:*:*:* Versions 9.10.8 p1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.8:rc1:*:*:*:*:*:* Versions 9.10.8 rc1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.8:rc2:*:*:*:*:*:* Versions 9.10.8 rc2 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.11.5:-:*:*:*:*:*:* Versions 9.11.5 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.11.5:p1:*:*:*:*:*:* Versions 9.11.5 p1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.11.5:rc1:*:*:*:*:*:* Versions 9.11.5 rc1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.11.5:s3:*:*:supported_preview:*:*:* Versions 9.11.5 s3 Vulnerable ·ISC
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2018-5744
- 2026-10-03 Alias added: GHSA-xcc7-r4h9-f7ph
References
Advisory 1
More ISC Bind vulnerabilities
- TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
- TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
- TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
- TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
- TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
- TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
Sources
- CVE-2018-5744 · CVE Program
- CVE-2018-5744 · NVD
- FIRST EPSS
- GHSA-xcc7-r4h9-f7ph · GitHub Advisory Database · CC BY 4.0
- CVE-2018-5744 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences