Out-of-bounds read in LibRaw
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 5 fixed, 3 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
An error within the "kodak_radc_load_raw()" function (internal/dcraw_common.cpp) related to the "buf" variable in LibRaw versions prior to 0.18.7 can be exploited to cause an out-of-bounds read memory access and subsequently cause a crash.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | LibRaw | before 0.18.7 | 0.18.7 | Patch available | CNA |
- LibRaw Vendor— Affected before 0.18.7 Fixed in 0.18.7 Patch available CNA
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:libraw:libraw:*:*:*:*:*:*:*:* | before 0.18.7 | Vulnerable | LibRaw |
| cpe:2.3:o:redhat:enterprise_linux_desktop:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_workstation:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* | 16.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:17.10:*:*:*:*:*:*:* | 17.10 | Vulnerable | Canonical |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
- cpe:2.3:a:libraw:libraw:*:*:*:*:*:*:*:* Versions before 0.18.7 Vulnerable ·LibRaw
- cpe:2.3:o:redhat:enterprise_linux_desktop:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_workstation:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* Versions 16.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:17.10:*:*:*:*:*:*:* Versions 17.10 Vulnerable ·Canonical
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
Remediation
- Fix · CNA LibRaw Fixed in 0.18.7
Red Hat 1 advisory
- RHSA-2018:3065 Released 2018-10-30 · Red Hat rating Moderatelibkdcraw security update
- Red Hat Enterprise Linux Client (v. 7) libkdcraw-4.10.5-5.el7
- Red Hat Enterprise Linux Client Optional (v. 7) libkdcraw-devel-4.10.5-5.el7
- Red Hat Enterprise Linux Server (v. 7) libkdcraw-4.10.5-5.el7, libkdcraw-devel-4.10.5-5.el7
- Red Hat Enterprise Linux Workstation (v. 7) libkdcraw-4.10.5-5.el7, libkdcraw-devel-4.10.5-5.el7
- Red Hat Enterprise Linux for ARM and IBM Power LE (POWER9) Server (v. 7) libkdcraw-4.10.5-5.el7, libkdcraw-devel-4.10.5-5.el7
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
LibRaw — RHSA-2018:3065
5 records Highest priority Priority MEDIUM 2 MEDIUM, 3 LOW
Other records, highest priority first
- TI-2018-04205 Out-of-bounds write in LibRawPriority MEDIUM 42
- TI-2018-04200 Out-of-bounds write in LibRawPriority LOW 34
- TI-2018-04201 NULL pointer dereference in LibRawPriority LOW 33
- Advisory ·
LibRaw — USN-3615-1
5 records Highest priority Priority MEDIUM 2 MEDIUM, 3 LOW
Other records, highest priority first
- TI-2017-12450 Memory corruption in LibRawPriority MEDIUM 42
- TI-2018-04200 Out-of-bounds write in LibRawPriority LOW 34
- TI-2018-04201 NULL pointer dereference in LibRawPriority LOW 33
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 5 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 6 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux Client (v. 7) | Fixed | RHSA-2018:3065 |
| Red Hat Enterprise Linux Client Optional (v. 7) | Fixed | RHSA-2018:3065 |
| Red Hat Enterprise Linux Server (v. 7) | Fixed | RHSA-2018:3065 |
| Red Hat Enterprise Linux Workstation (v. 7) | Fixed | RHSA-2018:3065 |
| Red Hat Enterprise Linux for ARM and IBM Power LE (POWER9) Server (v. 7) | Fixed | RHSA-2018:3065 |
Not affected: 2 products
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2018-5802
- 2026-10-03 Alias added: GHSA-j2qq-rw4v-jjx2
References
Advisory 5
Sources
- CVE-2018-5802 · CVE Program
- CVE-2018-5802 · NVD
- FIRST EPSS
- GHSA-j2qq-rw4v-jjx2 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-5802 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences