Integer overflow in LibRaw
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-190 and the CVSS impact.
Summary
An integer overflow error within the "parse_qt()" function (internal/dcraw_common.cpp) in LibRaw versions prior to 0.18.12 can be exploited to trigger an infinite loop via a specially crafted Apple QuickTime file.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | LibRaw | before 0.18.12 | 0.18.12 | Patch available | CNA |
- LibRaw Vendor— Affected before 0.18.12 Fixed in 0.18.12 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:libraw:libraw:*:*:*:*:*:*:*:* | before 0.18.12 | Vulnerable | LibRaw |
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* | 16.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* | 18.04 | Vulnerable | Canonical |
- cpe:2.3:a:libraw:libraw:*:*:*:*:*:*:*:* Versions before 0.18.12 Vulnerable ·LibRaw
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* Versions 16.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
Remediation
- Fix · CNA LibRaw Fixed in 0.18.12
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
LibRaw — USN-3838-1
7 records Highest priority Priority MEDIUM 2 MEDIUM, 5 LOW
Other records, highest priority first
- TI-2018-04210 Out-of-bounds write in LibRawPriority MEDIUM 42
- TI-2018-04207 Out-of-bounds read in LibRawPriority MEDIUM 42
- TI-2018-04216 Integer overflow in LibRawPriority LOW 33
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 2 products
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2018-5815
- 2026-10-03 Alias added: GHSA-j6px-673q-87gh
References
Sources
- CVE-2018-5815 · CVE Program
- CVE-2018-5815 · NVD
- FIRST EPSS
- GHSA-j6px-673q-87gh · GitHub Advisory Database · CC BY 4.0
- CVE-2018-5815 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences