Use after free in Google Chrome
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-416 and the CVSS impact.
Summary
Use after free in PDFium in Google Chrome prior to 64.0.3282.119 allowed a remote attacker to potentially exploit heap corruption via a crafted PDF file.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Chrome | before 64.0.3282.119 | 64.0.3282.119 | Patch available | CNA |
- Chrome VendorGoogle Affected before 64.0.3282.119 Fixed in 64.0.3282.119 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* | before 64.0.3282.119 | Vulnerable | |
| cpe:2.3:o:redhat:enterprise_linux_desktop:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_workstation:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* Versions before 64.0.3282.119 Vulnerable ·Google
- cpe:2.3:o:redhat:enterprise_linux_desktop:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_workstation:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · CNA Chrome (Google) Fixed in 64.0.3282.119
Red Hat 1 advisory
- RHSA-2018:0265 Released 2018-02-01 · Red Hat rating Importantchromium-browser security update
- Red Hat Enterprise Linux Desktop Supplementary (v. 6) chromium-browser-64.0.3282.119-1.el6_9
- Red Hat Enterprise Linux Server Supplementary (v. 6) chromium-browser-64.0.3282.119-1.el6_9
- Red Hat Enterprise Linux Workstation Supplementary (v. 6) chromium-browser-64.0.3282.119-1.el6_9
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Google Chrome — RHSA-2018:0265
22 records Highest priority Priority MEDIUM 5 MEDIUM, 17 LOW
Other records, highest priority first
- TI-2018-04406 Improper input validation in Google ChromePriority MEDIUM 42
- TI-2018-04416 Use after free in Google ChromePriority MEDIUM 41
- TI-2018-04398 Information disclosure in Google ChromePriority MEDIUM 41
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux Desktop Supplementary (v. 6) | Fixed | RHSA-2018:0265 |
| Red Hat Enterprise Linux Server Supplementary (v. 6) | Fixed | RHSA-2018:0265 |
| Red Hat Enterprise Linux Workstation Supplementary (v. 6) | Fixed | RHSA-2018:0265 |
Timeline
- 2026-10-02 Threatist record created from CVE-2018-6031
- 2026-10-03 Alias added: GHSA-v6mm-vqxm-hhgv
References
More Google Chrome vulnerabilities
- TI-2025-09686 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.8
- TI-2024-07390 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04898 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04600 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04346 Use after free in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2023-05824 Integer overflow in Google Chrome KEVCVSS 3.1CRITICAL 9.6
Sources
- CVE-2018-6031 · CVE Program
- CVE-2018-6031 · NVD
- FIRST EPSS
- GHSA-v6mm-vqxm-hhgv · GitHub Advisory Database · CC BY 4.0
- CVE-2018-6031 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences