Incorrect handling of confusable characters in URL Formatter in Google Chrome prior to…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and Red Hat.
Summary
Incorrect handling of confusable characters in URL Formatter in Google Chrome prior to 66.0.3359.117 allowed a remote attacker to perform domain spoofing via IDN homographs via a crafted HTML page.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Chrome | before 66.0.3359.117 | 66.0.3359.117 | Patch available | CNA |
- Chrome VendorGoogle Affected before 66.0.3359.117 Fixed in 66.0.3359.117 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:redhat:linux_desktop:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:linux_server:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:linux_workstation:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* | before 66.0.3359.117 | Vulnerable |
- cpe:2.3:o:redhat:linux_desktop:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:linux_server:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:linux_workstation:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* Versions before 66.0.3359.117 Vulnerable ·Google
Remediation
- Fix · CNA Chrome (Google) Fixed in 66.0.3359.117
Red Hat 1 advisory
- RHSA-2018:1195 Released 2018-04-23 · Red Hat rating Criticalchromium-browser security update
- Red Hat Enterprise Linux Desktop Supplementary (v. 6) chromium-browser-66.0.3359.117-1.el6_9
- Red Hat Enterprise Linux Server Supplementary (v. 6) chromium-browser-66.0.3359.117-1.el6_9
- Red Hat Enterprise Linux Workstation Supplementary (v. 6) chromium-browser-66.0.3359.117-1.el6_9
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Google Chrome 66.0.3359.117
21 records Highest priority Priority MEDIUM 8 MEDIUM, 13 LOW
Other records, highest priority first
- TI-2018-04452 Integer overflow in Google ChromePriority MEDIUM 50
- TI-2018-04511 Unrestricted file upload in Google ChromePriority MEDIUM 44
- TI-2018-04450 Integer overflow in Google ChromePriority MEDIUM 44
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux Desktop Supplementary (v. 6) | Fixed | RHSA-2018:1195 |
| Red Hat Enterprise Linux Server Supplementary (v. 6) | Fixed | RHSA-2018:1195 |
| Red Hat Enterprise Linux Workstation Supplementary (v. 6) | Fixed | RHSA-2018:1195 |
Timeline
- 2026-10-02 Threatist record created from CVE-2018-6108
- 2026-10-03 Alias added: GHSA-2mpj-5wq9-73rr
References
More Google Chrome vulnerabilities
- TI-2025-09686 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.8
- TI-2024-07390 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04898 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04600 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04346 Use after free in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2023-05824 Integer overflow in Google Chrome KEVCVSS 3.1CRITICAL 9.6
Sources
- CVE-2018-6108 · CVE Program
- CVE-2018-6108 · NVD
- FIRST EPSS
- GHSA-2mpj-5wq9-73rr · GitHub Advisory Database · CC BY 4.0
- CVE-2018-6108 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences