Improper input validation in Google Chrome
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and Red Hat.
Summary
Insufficient target checks on the chrome.debugger API in DevTools in Google Chrome prior to 67.0.3396.62 allowed an attacker who convinced a user to install a malicious extension to execute arbitrary code via a crafted Chrome Extension.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Chrome | before 67.0.3396.62 | 67.0.3396.62 | Patch available | CNA |
- Chrome VendorGoogle Affected before 67.0.3396.62 Fixed in 67.0.3396.62 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* | before 67.0.3396.62 | Vulnerable | |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:redhat:enterprise_linux_desktop:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_workstation:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
- cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* Versions before 67.0.3396.62 Vulnerable ·Google
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:redhat:enterprise_linux_desktop:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_workstation:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
Remediation
- Fix · CNA Chrome (Google) Fixed in 67.0.3396.62
Red Hat 1 advisory
- RHSA-2018:1815 Released 2018-06-07 · Red Hat rating Importantchromium-browser security update
- Red Hat Enterprise Linux Desktop Supplementary (v. 6) chromium-browser-67.0.3396.62-2.el6_9
- Red Hat Enterprise Linux Server Supplementary (v. 6) chromium-browser-67.0.3396.62-2.el6_9
- Red Hat Enterprise Linux Workstation Supplementary (v. 6) chromium-browser-67.0.3396.62-2.el6_9
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Google Chrome — DSA-4237
14 records Highest priority Priority MEDIUM 8 MEDIUM, 6 LOW
Other records, highest priority first
- TI-2018-04486 Out-of-bounds write in Google ChromePriority MEDIUM 48
- TI-2018-04487 Use after free in Google ChromePriority MEDIUM 45
- TI-2018-04500 Improper input validation in Google ChromePriority MEDIUM 43
- Advisory ·
Google Chrome — RHSA-2018:1815
13 records Highest priority Priority MEDIUM 7 MEDIUM, 6 LOW
Other records, highest priority first
- TI-2018-04486 Out-of-bounds write in Google ChromePriority MEDIUM 48
- TI-2018-04487 Use after free in Google ChromePriority MEDIUM 45
- TI-2018-04500 Improper input validation in Google ChromePriority MEDIUM 43
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux Desktop Supplementary (v. 6) | Fixed | RHSA-2018:1815 |
| Red Hat Enterprise Linux Server Supplementary (v. 6) | Fixed | RHSA-2018:1815 |
| Red Hat Enterprise Linux Workstation Supplementary (v. 6) | Fixed | RHSA-2018:1815 |
Timeline
- 2026-10-02 Threatist record created from CVE-2018-6139
- 2026-10-03 Alias added: GHSA-3vv5-773m-mqg8
References
More Google Chrome vulnerabilities
- TI-2025-09686 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.8
- TI-2024-07390 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04898 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04600 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04346 Use after free in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2023-05824 Integer overflow in Google Chrome KEVCVSS 3.1CRITICAL 9.6
Sources
- CVE-2018-6139 · CVE Program
- CVE-2018-6139 · NVD
- FIRST EPSS
- GHSA-3vv5-773m-mqg8 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-6139 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences