OS command injection in Meta react-dev-utils
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
react-dev-utils on Windows allows developers to run a local webserver for accepting various commands, including a command to launch an editor. The input to that command was not properly sanitized, allowing an attacker who can make a network request to the server (either via CSRF or by direct request) to execute arbitrary commands on the targeted system. This issue affects multiple branches: 1.x.x prior to 1.0.4, 2.x.x prior to 2.0.2, 3.x.x prior to 3.1.2, 4.x.x prior to 4.2.2, and 5.x.x prior to 5.0.2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Meta | react-dev-utils | 5.0.2; 5.0.0 and later; 4.2.2; 4.0.0 and later; 3.1.2; 3.0.0 and later; 2.0.2; 2.0.0 and later; 1.0.4; 1.0.0 and later | — | No fix listed | CNA |
| — | react-dev-utils (npm) | 1.0.0 to before 1.0.4 | 1.0.4 | Patch available | GHSA-29gp-92wp-94q8 |
| — | react-dev-utils (npm) | 2.0.0 to before 2.0.2 | 2.0.2 | Patch available | GHSA-29gp-92wp-94q8 |
| — | react-dev-utils (npm) | 3.0.0 to before 3.1.2 | 3.1.2 | Patch available | GHSA-29gp-92wp-94q8 |
| — | react-dev-utils (npm) | 4.0.0 to before 4.2.2 | 4.2.2 | Patch available | GHSA-29gp-92wp-94q8 |
| — | react-dev-utils (npm) | 5.0.0 to before 5.0.2 | 5.0.2 | Patch available | GHSA-29gp-92wp-94q8 |
- react-dev-utils VendorMeta Affected 5.0.2; 5.0.0 and later; 4.2.2; 4.0.0 and later; 3.1.2; 3.0.0 and later; 2.0.2; 2.0.0 and later; 1.0.4; 1.0.0 and later Fixed in — No fix listed CNA
- react-dev-utils (npm) Vendor— Affected 1.0.0 to before 1.0.4 Fixed in 1.0.4 Patch available GHSA-29gp-92wp-94q8
- react-dev-utils (npm) Vendor— Affected 2.0.0 to before 2.0.2 Fixed in 2.0.2 Patch available GHSA-29gp-92wp-94q8
- react-dev-utils (npm) Vendor— Affected 3.0.0 to before 3.1.2 Fixed in 3.1.2 Patch available GHSA-29gp-92wp-94q8
- react-dev-utils (npm) Vendor— Affected 4.0.0 to before 4.2.2 Fixed in 4.2.2 Patch available GHSA-29gp-92wp-94q8
- react-dev-utils (npm) Vendor— Affected 5.0.0 to before 5.0.2 Fixed in 5.0.2 Patch available GHSA-29gp-92wp-94q8
CPE configurations NVD · 2
Remediation
- Fix · GHSA-29gp-92wp-94q8 react-dev-utils (npm) Fixed in 1.0.4 Advisory →
- Fix · GHSA-29gp-92wp-94q8 react-dev-utils (npm) Fixed in 2.0.2 Advisory →
- Fix · GHSA-29gp-92wp-94q8 react-dev-utils (npm) Fixed in 3.1.2 Advisory →
- Fix · GHSA-29gp-92wp-94q8 react-dev-utils (npm) Fixed in 4.2.2 Advisory →
- Fix · GHSA-29gp-92wp-94q8 react-dev-utils (npm) Fixed in 5.0.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-6342
- 2026-10-03 Alias added: GHSA-29gp-92wp-94q8
References
Advisory 4
More Meta React-dev-utils vulnerabilities
- TI-2021-06350 OS command injection in Meta react-dev-utils CVSS 3.1MEDIUM 5.6
Sources
- CVE-2018-6342 · CVE Program
- CVE-2018-6342 · NVD
- FIRST EPSS
- GHSA-29gp-92wp-94q8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences