Jenkins before 2.107 and Jenkins LTS before 2.89.4 did not properly prevent specifying…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-22 and the CVSS impact.
Summary
Jenkins before 2.107 and Jenkins LTS before 2.89.4 did not properly prevent specifying relative paths that escape a base directory for URLs accessing plugin resource files. This allowed users with Overall/Read permission to download files from the Jenkins master they should not have access to. On Windows, any file accessible to the Jenkins master process could be downloaded. On other operating systems, any file within the Jenkins home directory accessible to the Jenkins master process could be downloaded.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 2.89.4 | 2.89.4 | Patch available | GHSA-5p59-v5wm-77v4 |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 2.90 to before 2.107 | 2.107 | Patch available | GHSA-5p59-v5wm-77v4 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.89.4 Fixed in 2.89.4 Patch available GHSA-5p59-v5wm-77v4
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.90 to before 2.107 Fixed in 2.107 Patch available GHSA-5p59-v5wm-77v4
CPE configurations NVD · 3
Remediation
- Fix · GHSA-5p59-v5wm-77v4 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.89.4 Advisory →
- Fix · GHSA-5p59-v5wm-77v4 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.107 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Enterprise 3 | Affected | No fix yet |
Timeline
- 2026-10-02 Threatist record created from CVE-2018-6356
- 2026-10-03 Alias added: GHSA-5p59-v5wm-77v4
- 2026-10-16 EPSS moved to the 90th–95th percentile
References
Advisory 3
Other 5
- https://github.com/jenkinsci/jenkins/commit/9de62915807deab61d6e780eed660428f9889b51
- https://github.com/jenkinsci/jenkins/commit/eb03a42078f29dbed3742b8740c95e02890e4545
- https://github.com/jenkinsci/jenkins
- https://jenkins.io/security/advisory/2018-02-14
- https://web.archive.org/web/20200227130607/http://www.securityfocus.com/bid/103037
Sources
- CVE-2018-6356 · CVE Program
- CVE-2018-6356 · NVD
- FIRST EPSS
- GHSA-5p59-v5wm-77v4 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-6356 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences