The SAML2 library before 1.10.4, 2.x before 2.3.5, and 3.x before 3.1.1 in SimpleSAMLphp…
Priority LOW 36CWE-74Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
The SAML2 library before 1.10.4, 2.x before 2.3.5, and 3.x before 3.1.1 in SimpleSAMLphp has a Regular Expression Denial of Service vulnerability for fraction-of-seconds data in a timestamp.
Why it matters now
EPSS 0.01696 77th percentileScored 2026-11-07
Fix Fixed simplesamlphp/saml2 (Packagist): 1.10.4, 2.3.5, 3.1.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | simplesamlphp/saml2 (Packagist) | before 1.10.4 | 1.10.4 | Patch available | GHSA-hhm8-2j4g-mpgg |
| — | simplesamlphp/saml2 (Packagist) | 2.0 to before 2.3.5 | 2.3.5 | Patch available | GHSA-hhm8-2j4g-mpgg |
| — | simplesamlphp/saml2 (Packagist) | 3.0 to before 3.1.1 | 3.1.1 | Patch available | GHSA-hhm8-2j4g-mpgg |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- simplesamlphp/saml2 (Packagist) Vendor— Affected before 1.10.4 Fixed in 1.10.4 Patch available GHSA-hhm8-2j4g-mpgg
- simplesamlphp/saml2 (Packagist) Vendor— Affected 2.0 to before 2.3.5 Fixed in 2.3.5 Patch available GHSA-hhm8-2j4g-mpgg
- simplesamlphp/saml2 (Packagist) Vendor— Affected 3.0 to before 3.1.1 Fixed in 3.1.1 Patch available GHSA-hhm8-2j4g-mpgg
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simplesamlphp:saml2:*:*:*:*:*:*:*:* | 1.0.0 to before 1.10.4; 2.0.0 to before 2.3.5; 3.0.0 to before 3.1.1 | Vulnerable | simplesamlphp |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:simplesamlphp:saml2:*:*:*:*:*:*:*:* Versions 1.0.0 to before 1.10.4; 2.0.0 to before 2.3.5; 3.0.0 to before 3.1.1 Vulnerable ·simplesamlphp
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-hhm8-2j4g-mpgg simplesamlphp/saml2 (Packagist) Fixed in 1.10.4 Advisory →
- Fix · GHSA-hhm8-2j4g-mpgg simplesamlphp/saml2 (Packagist) Fixed in 2.3.5 Advisory →
- Fix · GHSA-hhm8-2j4g-mpgg simplesamlphp/saml2 (Packagist) Fixed in 3.1.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2018-6519
- 2026-10-03 Alias added: GHSA-hhm8-2j4g-mpgg
References
Sources
- CVE-2018-6519 · CVE Program
- CVE-2018-6519 · NVD
- FIRST EPSS
- GHSA-hhm8-2j4g-mpgg · GitHub Advisory Database · CC BY 4.0
- CVE-2018-6519 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences