AppArmor cupsd Sandbox Bypass Due to Use of Hard Links
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA.
Summary
The CUPS AppArmor profile incorrectly confined the dnssd backend due to use of hard links. A local attacker could possibly use this issue to escape confinement. This flaw affects versions prior to 2.2.7-1ubuntu2.1 in Ubuntu 18.04 LTS, prior to 2.2.4-7ubuntu3.1 in Ubuntu 17.10, prior to 2.1.3-4ubuntu0.5 in Ubuntu 16.04 LTS, and prior to 1.7.2-0ubuntu1.10 in Ubuntu 14.04 LTS.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | cups | before 2.2.7-1ubuntu2.1 | 2.2.7-1ubuntu2.1 | Patch available | CNA |
| — | cups | before 2.2.4-7ubuntu3.1 | 2.2.4-7ubuntu3.1 | Patch available | CNA |
| — | cups | before 2.1.3-4ubuntu0.5 | 2.1.3-4ubuntu0.5 | Patch available | CNA |
| — | cups | before 1.7.2-0ubuntu1.10 | 1.7.2-0ubuntu1.10 | Patch available | CNA |
- cups Vendor— Affected before 2.2.7-1ubuntu2.1 Fixed in 2.2.7-1ubuntu2.1 Patch available CNA
- cups Vendor— Affected before 2.2.4-7ubuntu3.1 Fixed in 2.2.4-7ubuntu3.1 Patch available CNA
- cups Vendor— Affected before 2.1.3-4ubuntu0.5 Fixed in 2.1.3-4ubuntu0.5 Patch available CNA
- cups Vendor— Affected before 1.7.2-0ubuntu1.10 Fixed in 1.7.2-0ubuntu1.10 Patch available CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cups:cups:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | cups |
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* | 16.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:17.10:*:*:*:*:*:*:* | 17.10 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* | 18.04 | Vulnerable | Canonical |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:cups:cups:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·cups
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* Versions 16.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:17.10:*:*:*:*:*:*:* Versions 17.10 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · CNA cups Fixed in 2.2.7-1ubuntu2.1
- Fix · CNA cups Fixed in 2.2.4-7ubuntu3.1
- Fix · CNA cups Fixed in 2.1.3-4ubuntu0.5
- Fix · CNA cups Fixed in 1.7.2-0ubuntu1.10
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Virtualization 4
Timeline
- 2026-10-02 Threatist record created from CVE-2018-6553
- 2026-10-03 Alias added: GHSA-2f8v-v7q3-8gqv
References
Sources
- CVE-2018-6553 · CVE Program
- CVE-2018-6553 · NVD
- FIRST EPSS
- GHSA-2f8v-v7q3-8gqv · GitHub Advisory Database · CC BY 4.0
- CVE-2018-6553 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences