Insecure temporary file use in base-files
Priority LOW 31CWE-59Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
The MOTD update script in the base-files package in Ubuntu 18.04 LTS before 10.1ubuntu2.2, and Ubuntu 18.10 before 10.1ubuntu6 incorrectly handled temporary files. A local attacker could use this issue to cause a denial of service, or possibly escalate privileges if kernel symlink restrictions were disabled.
Why it matters now
EPSS 0.00373 31st percentileScored 2026-11-07
Fix Fixed base-files (Ubuntu): 10.1ubuntu2.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Ubuntu | base-files | before 10.1ubuntu2.2 | 10.1ubuntu2.2 | Patch available | CNA |
- base-files VendorUbuntu Affected before 10.1ubuntu2.2 Fixed in 10.1ubuntu2.2 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:base-files_project:base-files:10.1ubuntu2.2:*:*:*:*:*:*:* | 10.1ubuntu2.2 | Vulnerable | Base-files Project |
| cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* | 18.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:18.10:*:*:*:*:*:*:* | 18.10 | Vulnerable | Canonical |
- cpe:2.3:a:base-files_project:base-files:10.1ubuntu2.2:*:*:*:*:*:*:* Versions 10.1ubuntu2.2 Vulnerable ·Base-files Project
- cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:18.10:*:*:*:*:*:*:* Versions 18.10 Vulnerable ·Canonical
Remediation
- Fix · CNA base-files (Ubuntu) Fixed in 10.1ubuntu2.2
Timeline
- 2026-10-02 Threatist record created from CVE-2018-6557
- 2026-10-03 Alias added: GHSA-vfrm-87wr-xvjf
References
Advisory 1
More Ubuntu vulnerabilities
- TI-2021-02452 Incorrect authorization in Ubuntu linux kernel KEVCVSS 3.1HIGH 8.8
- TI-2007-05153 Stack-based buffer overflow in the cons_options function in options.c in dhcpd in OpenBSD… CVSS 2.0HIGH 7.2
- TI-2004-01032 Multiple vulnerabilities in the IGMP functionality for Linux kernel 2.4.22 to 2.4.28, and… CVSS 2.0HIGH 10.0
- TI-2004-00896 Multiple buffer overflows in libXML 2.6.12 and 2.6.13 (libxml2), and possibly other… CVSS 2.0HIGH 10.0
- TI-2004-00800 Buffer overflow in the QFILEPATHINFO request handler in Samba 3.0.x through 3.0.7 may… CVSS 2.0HIGH 10.0
- TI-2004-00962 Buffer overflow in the exif_read_data function in PHP before 4.3.10 and PHP 5.x up to… CVSS 2.0HIGH 10.0
Sources
- CVE-2018-6557 · CVE Program
- CVE-2018-6557 · NVD
- FIRST EPSS
- GHSA-vfrm-87wr-xvjf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences