webhooks/base.py in Anymail (aka django-anymail) before 1.2.1 is prone to a timing attack…
Priority MEDIUM 44CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
webhooks/base.py in Anymail (aka django-anymail) before 1.2.1 is prone to a timing attack vulnerability on the WEBHOOK_AUTHORIZATION secret, which allows remote attackers to post arbitrary e-mail tracking events.
Why it matters now
EPSS 0.02609 85th percentileScored 2026-11-07
Fix Fixed django-anymail (PyPI): 1.2.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | django-anymail (PyPI) | before 1.2.1 | 1.2.1 | Patch available | GHSA-hxf9-7h4c-f5jv |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- django-anymail (PyPI) Vendor— Affected before 1.2.1 Fixed in 1.2.1 Patch available GHSA-hxf9-7h4c-f5jv
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:django-anymail_project:django-anymail:*:*:*:*:*:*:*:* | before 1.2.1 | Vulnerable | Django-anymail Project |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:django-anymail_project:django-anymail:*:*:*:*:*:*:*:* Versions before 1.2.1 Vulnerable ·Django-anymail Project
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-hxf9-7h4c-f5jv django-anymail (PyPI) Fixed in 1.2.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-6596
- 2026-10-03 Alias added: GHSA-hxf9-7h4c-f5jv
References
Patch 3
Advisory 3
Sources
- CVE-2018-6596 · CVE Program
- CVE-2018-6596 · NVD
- FIRST EPSS
- GHSA-hxf9-7h4c-f5jv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences