Read the docs
TI-2018-04991 Aliases CVE-2018-6835GHSA-mvmv-rq2j-97p2

node/hooks/express/apicalls.js in Etherpad Lite before v1.6.3 mishandles JSONP, which…

Priority MEDIUM 46CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.

Summary

node/hooks/express/apicalls.js in Etherpad Lite before v1.6.3 mishandles JSONP, which allows remote attackers to bypass intended access restrictions.

Why it matters now

EPSS 0.02286 83rd percentileScored 2026-11-07
Fix Fixed ep_etherpad-lite (npm): 1.6.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—ep_etherpad-lite (npm)before 1.6.31.6.3Patch availableGHSA-mvmv-rq2j-97p2
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • ep_etherpad-lite (npm) Vendor— Affected before 1.6.3 Fixed in 1.6.3 Patch available GHSA-mvmv-rq2j-97p2

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:etherpad:etherpad:*:*:*:*:*:*:*:*before 1.6.3VulnerableEtherpad
  • cpe:2.3:a:etherpad:etherpad:*:*:*:*:*:*:*:* Versions before 1.6.3 Vulnerable ·Etherpad

Remediation

  • Fix · GHSA-mvmv-rq2j-97p2 ep_etherpad-lite (npm) Fixed in 1.6.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-6835
  2. 2026-10-03 Alias added: GHSA-mvmv-rq2j-97p2

References

  • TI-2021-19608 Admin privilege escalation and arbitrary code execution via malicious *.etherpad imports CVSS 3.1CRITICAL 9.9
  • TI-2018-06747 Etherpad 1.6.3 before 1.6.4 allows an attacker to execute arbitrary code. CVSS 3.0CRITICAL 9.8
  • TI-2015-02917 Directory traversal vulnerability in node/utils/Minify.js in Etherpad 1.1.1 through 1.5.2… CVSS 3.0HIGH 7.5
  • TI-2018-06748 Etherpad 1.5.x and 1.6.x before 1.6.4 allows an attacker to execute arbitrary code on the… CVSS 3.0HIGH 8.1
  • TI-2015-03442 Directory traversal vulnerability in node/hooks/express/tests.js in Etherpad frontend tests before 1.6.1. CVSS 3.0HIGH 7.5
  • TI-2015-02926 Directory traversal vulnerability in node/utils/Minify.js in Etherpad 1.1.2 through 1.5.4… CVSS 3.1HIGH 7.5
See all 15 →

Sources