OS command injection in Aruba Instant
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-78.
Summary
A command injection vulnerability is present that permits an unauthenticated user with access to the Aruba Instant web interface to execute arbitrary system commands within the underlying operating system. An attacker could use this ability to copy files, read configuration, write files, delete files, or reboot the device. Workaround: Block access to the Aruba Instant web interface from all untrusted users. Resolution: Fixed in Aruba Instant 4.2.4.12, 6.5.4.11, 8.3.0.6, and 8.4.0.1
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Aruba Instant (IAP) | Aruba Instant 4.x prior to 6.4.4.8 - 4.2.4.12 Aruba Instant 6.5.x prior to 6.5.4.11 Aruba Instant 8.3.x prior to 8.3.0.6 Aruba Instant 8.4.x prior to 8.4.0.1 | — | No fix listed | CNA |
- Aruba Instant (IAP) Vendor— Affected Aruba Instant 4.x prior to 6.4.4.8 - 4.2.4.12 Aruba Instant 6.5.x prior to 6.5.4.11 Aruba Instant 8.3.x prior to 8.3.0.6 Aruba Instant 8.4.x prior to 8.4.0.1 Fixed in — No fix listed CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:arubanetworks:aruba_instant:*:*:*:*:*:*:*:* | 4.0 to before 4.2.4.12; 6.5.0 to before 6.5.4.11; 8.3.0 to before 8.3.0.6; 8.4.0 to before 8.4.0.1 | Vulnerable | Arubanetworks |
| cpe:2.3:o:siemens:scalance_w1750d_firmware:*:*:*:*:*:*:*:* | before 8.4.0.1 | Vulnerable | Siemens |
| cpe:2.3:h:siemens:scalance_w1750d:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Siemens |
- cpe:2.3:a:arubanetworks:aruba_instant:*:*:*:*:*:*:*:* Versions 4.0 to before 4.2.4.12; 6.5.0 to before 6.5.4.11; 8.3.0 to before 8.3.0.6; 8.4.0 to before 8.4.0.1 Vulnerable ·Arubanetworks
- cpe:2.3:o:siemens:scalance_w1750d_firmware:*:*:*:*:*:*:*:* Versions before 8.4.0.1 Vulnerable ·Siemens
- cpe:2.3:h:siemens:scalance_w1750d:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Siemens
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2018-7084
- 2026-10-03 Alias added: GHSA-pxhj-rpvv-rcrx
References
Sources
- CVE-2018-7084 · CVE Program
- CVE-2018-7084 · NVD
- FIRST EPSS
- GHSA-pxhj-rpvv-rcrx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences