uWSGI before 2.0.17 mishandles a DOCUMENT_ROOT check during use of the --php-docroot…
Priority HIGH 70CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
uWSGI before 2.0.17 mishandles a DOCUMENT_ROOT check during use of the --php-docroot option, allowing directory traversal.
Why it matters now
EPSS 0.69423 99th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed uWSGI (PyPI): 2.0.17
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | uWSGI (PyPI) | before 2.0.17 | 2.0.17 | Patch available | GHSA-h2vm-c85r-5vh5 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- uWSGI (PyPI) Vendor— Affected before 2.0.17 Fixed in 2.0.17 Patch available GHSA-h2vm-c85r-5vh5
Remediation
- Fix · GHSA-h2vm-c85r-5vh5 uWSGI (PyPI) Fixed in 2.0.17 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2018-7490
- 2026-10-03 Alias added: GHSA-h2vm-c85r-5vh5
References
Exploit 1
Advisory 3
Sources
- CVE-2018-7490 · CVE Program
- CVE-2018-7490 · NVD
- FIRST EPSS
- GHSA-h2vm-c85r-5vh5 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-7490 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences