An issue was discovered in Django 2.0 before 2.0.3, 1.11 before 1.11.11, and 1.8 before…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Partial Red Hat: 4 fixed, 16 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
An issue was discovered in Django 2.0 before 2.0.3, 1.11 before 1.11.11, and 1.8 before 1.8.19. If django.utils.text.Truncator's chars() and words() methods were passed the html=True argument, they were extremely slow to evaluate certain inputs due to a catastrophic backtracking vulnerability in a regular expression. The chars() and words() methods are used to implement the truncatechars_html and truncatewords_html template filters, which were thus vulnerable.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Django (PyPI) | 2.0 to before 2.0.3 | 2.0.3 | Patch available | GHSA-2f9x-5v75-3qv4 |
| — | Django (PyPI) | 1.11 to before 1.11.11 | 1.11.11 | Patch available | GHSA-2f9x-5v75-3qv4 |
| — | Django (PyPI) | 1.8 to before 1.8.19 | 1.8.19 | Patch available | GHSA-2f9x-5v75-3qv4 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Django (PyPI) Vendor— Affected 2.0 to before 2.0.3 Fixed in 2.0.3 Patch available GHSA-2f9x-5v75-3qv4
- Django (PyPI) Vendor— Affected 1.11 to before 1.11.11 Fixed in 1.11.11 Patch available GHSA-2f9x-5v75-3qv4
- Django (PyPI) Vendor— Affected 1.8 to before 1.8.19 Fixed in 1.8.19 Patch available GHSA-2f9x-5v75-3qv4
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* | 16.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:17.10:*:*:*:*:*:*:* | 17.10 | Vulnerable | Canonical |
| cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* | 1.8 to before 1.8.19; 1.11 to before 1.11.11; 2.0 to before 2.0.3 | Vulnerable | djangoproject |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* Versions 16.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:17.10:*:*:*:*:*:*:* Versions 17.10 Vulnerable ·Canonical
- cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions 1.8 to before 1.8.19; 1.11 to before 1.11.11; 2.0 to before 2.0.3 Vulnerable ·djangoproject
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-2f9x-5v75-3qv4 Django (PyPI) Fixed in 2.0.3 Advisory →
- Fix · GHSA-2f9x-5v75-3qv4 Django (PyPI) Fixed in 1.11.11 Advisory →
- Fix · GHSA-2f9x-5v75-3qv4 Django (PyPI) Fixed in 1.8.19 Advisory →
Red Hat 2 advisories
- RHSA-2019:0265 Released 2019-02-04 · Red Hat rating ModerateRed Hat Gluster Storage Web Administration security update
- Red Hat Gluster 3.4 Web Administration Node Agent on RHEL-7 tendrl-collectd-selinux-1.5.4-3.el7rhgs, tendrl-commons-1.6.3-15.el7rhgs, tendrl-node-agent-1.6.3-15.el7rhgs +1
- Red Hat Gluster 3.4 Web Administration on RHEL-7 carbon-selinux-1.5.4-3.el7rhgs, graphite-web-1.1.4-1.el7rhgs, python-cachetools-1.0.3-1.1.el7rhgs +17
- RHSA-2018:2927 Released 2018-10-16 · Red Hat rating ImportantSatellite 6.4 security, bug fix, and enhancement update
- Red Hat Satellite 6.4 SOAPpy-0.11.6-17.el7, ansiblerole-insights-client-1.5-1.el7sat, candlepin-2.4.8-1.el7 +47
- Red Hat Satellite Capsule 6.4 SOAPpy-0.11.6-17.el7, ansiblerole-insights-client-1.5-1.el7sat, createrepo_c-0.7.4-1.el7sat +47
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ceph Storage 1.3 | Affected | No fix planned: Will not fix |
| Red Hat Ceph Storage 2 | Affected | No fix planned: Will not fix |
| Red Hat Ceph Storage 3 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux OpenStack Platform 6 (Juno) | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux OpenStack Platform 7 (Kilo) | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux OpenStack Platform 7 (Kilo) Operational Tools | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 10 (Newton) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 11 (Ocata) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 12 (Pike) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 13 (Queens) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 8 (Liberty) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 8 (Liberty) Operational Tools | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 9 (Mitaka) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 9 (Mitaka) Operational Tools | Affected | No fix planned: Will not fix |
| Red Hat Storage Console 2 | Affected | No fix planned: Will not fix |
| Red Hat Subscription Asset Manager | Affected | No fix planned: Will not fix |
| Red Hat Gluster 3.4 Web Administration Node Agent on RHEL-7 | Fixed | RHSA-2019:0265 |
| Red Hat Gluster 3.4 Web Administration on RHEL-7 | Fixed | RHSA-2019:0265 |
| Red Hat Satellite 6.4 | Fixed | RHSA-2018:2927 |
| Red Hat Satellite Capsule 6.4 | Fixed | RHSA-2018:2927 |
Timeline
- 2026-10-02 Threatist record created from CVE-2018-7537
- 2026-10-03 Alias added: GHSA-2f9x-5v75-3qv4
References
Advisory 8
Other 7
- https://github.com/django/django/commit/94c5da1d17a6b0d378866c66b605102c19f7988c
- https://github.com/django/django/commit/a91436360b79a6ff995c3e5018bcc666dfaf1539
- https://github.com/django/django/commit/d17974a287a6ea2e361daff88fcc004cbd6835fa
- https://github.com/django/django
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2018-6.yaml
- https://usn.ubuntu.com/3591-1
- https://www.djangoproject.com/weblog/2018/mar/06/security-releases
Sources
- CVE-2018-7537 · CVE Program
- CVE-2018-7537 · NVD
- FIRST EPSS
- GHSA-2f9x-5v75-3qv4 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-7537 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences