Memcpy parameter overlap in Google Snappy library 1.1.4, as used in Google TensorFlow…
Priority LOW 36CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
Memcpy parameter overlap in Google Snappy library 1.1.4, as used in Google TensorFlow before 1.7.1, could result in a crash or read from other parts of process memory.
Why it matters now
EPSS 0.00523 44th percentileScored 2026-11-07
Fix Fixed tensorflow (PyPI): 1.7.1tensorflow-gpu (PyPI): 1.7.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | tensorflow (PyPI) | 1.1.0 to before 1.7.1 | 1.7.1 | Patch available | GHSA-qx2v-j445-g354 |
| — | tensorflow-gpu (PyPI) | 1.1.0 to before 1.7.1 | 1.7.1 | Patch available | GHSA-qx2v-j445-g354 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- tensorflow (PyPI) Vendor— Affected 1.1.0 to before 1.7.1 Fixed in 1.7.1 Patch available GHSA-qx2v-j445-g354
- tensorflow-gpu (PyPI) Vendor— Affected 1.1.0 to before 1.7.1 Fixed in 1.7.1 Patch available GHSA-qx2v-j445-g354
Remediation
- Fix · GHSA-qx2v-j445-g354 tensorflow (PyPI) Fixed in 1.7.1 Advisory →
- Fix · GHSA-qx2v-j445-g354 tensorflow-gpu (PyPI) Fixed in 1.7.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-7577
- 2026-10-03 Alias added: GHSA-qx2v-j445-g354
References
Advisory 3
Other 5
- https://github.com/tensorflow/tensorflow/commit/dfa9921e6343727b05f42f8d4a918b19528ff994
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2019-225.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2019-232.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2019-207.yaml
- https://github.com/tensorflow/tensorflow
Sources
- CVE-2018-7577 · CVE Program
- CVE-2018-7577 · NVD
- FIRST EPSS
- GHSA-qx2v-j445-g354 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences