HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-347.
Summary
HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect check of return values in the signature validation utilities, allowing an attacker to get invalid signatures accepted as valid by forcing an error during validation. This occurs because of a dependency on PHP functionality that interprets a -1 error code as a true boolean value.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | simplesamlphp/saml2 (Packagist) | before 1.10.6 | 1.10.6 | Patch available | GHSA-g888-g2pp-82hf |
| — | simplesamlphp/saml2 (Packagist) | 2.0 to before 2.3.8 | 2.3.8 | Patch available | GHSA-g888-g2pp-82hf |
| — | simplesamlphp/saml2 (Packagist) | 3.0 to before 3.1.4 | 3.1.4 | Patch available | GHSA-g888-g2pp-82hf |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- simplesamlphp/saml2 (Packagist) Vendor— Affected before 1.10.6 Fixed in 1.10.6 Patch available GHSA-g888-g2pp-82hf
- simplesamlphp/saml2 (Packagist) Vendor— Affected 2.0 to before 2.3.8 Fixed in 2.3.8 Patch available GHSA-g888-g2pp-82hf
- simplesamlphp/saml2 (Packagist) Vendor— Affected 3.0 to before 3.1.4 Fixed in 3.1.4 Patch available GHSA-g888-g2pp-82hf
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* | before 1.15.4 | Vulnerable | simplesamlphp |
| cpe:2.3:a:simplesamlphp:saml2:*:*:*:*:*:*:*:* | 1.0.0 to before 1.10.6; 2.0.0 to before 2.3.8; 3.0.0 to before 3.1.4 | Vulnerable | simplesamlphp |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
- cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* Versions before 1.15.4 Vulnerable ·simplesamlphp
- cpe:2.3:a:simplesamlphp:saml2:*:*:*:*:*:*:*:* Versions 1.0.0 to before 1.10.6; 2.0.0 to before 2.3.8; 3.0.0 to before 3.1.4 Vulnerable ·simplesamlphp
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-g888-g2pp-82hf simplesamlphp/saml2 (Packagist) Fixed in 1.10.6 Advisory →
- Fix · GHSA-g888-g2pp-82hf simplesamlphp/saml2 (Packagist) Fixed in 2.3.8 Advisory →
- Fix · GHSA-g888-g2pp-82hf simplesamlphp/saml2 (Packagist) Fixed in 3.1.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2018-7711
- 2026-10-03 Alias added: GHSA-g888-g2pp-82hf
References
Advisory 3
Sources
- CVE-2018-7711 · CVE Program
- CVE-2018-7711 · NVD
- FIRST EPSS
- GHSA-g888-g2pp-82hf · GitHub Advisory Database · CC BY 4.0
- CVE-2018-7711 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences