Improper input validation in Apache CouchDB
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA.
Summary
Apache CouchDB administrative users can configure the database server via HTTP(S). Due to insufficient validation of administrator-supplied configuration settings via the HTTP API, it is possible for a CouchDB administrator user to escalate their privileges to that of the operating system's user that CouchDB runs under, by bypassing the blacklist of configuration settings that are not allowed to be modified via the HTTP API. This privilege escalation effectively allows an existing CouchDB admin user to gain arbitrary remote code execution, bypassing already disclosed CVE-2017-12636. Mitigation: All users should upgrade to CouchDB releases 1.7.2 or 2.1.2.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA Apache CouchDB (Apache Software Foundation) Fixed in 1.7.2
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2018-8007
- 2026-10-03 Alias added: GHSA-mqj2-xj98-r5xp
References
Exploit 1
Advisory 5
More Apache Couchdb vulnerabilities
- TI-2022-08521 Remote Code Execution Vulnerability in Packaging KEVCVSS 3.1CRITICAL 9.8
- TI-2017-09360 Improper privilege management in Apache CouchDB CVSS 3.0CRITICAL 9.8
- TI-2017-09361 OS command injection in Apache CouchDB CVSS 3.0HIGH 7.2
- TI-2020-01879 Missing authentication in Apache CouchDB CVSS 3.1CRITICAL 9.8
- TI-2018-08426 CouchDB administrative users before 2.2.0 can configure the database server via HTTP(S). CVSS 3.0HIGH 7.2
- TI-2014-02145 Apache CouchDB 1.5.0 and earlier allows remote attackers to cause a denial of service… CVSS 2.0MEDIUM 5.0
Sources
- CVE-2018-8007 · CVE Program
- CVE-2018-8007 · NVD
- FIRST EPSS
- GHSA-mqj2-xj98-r5xp · GitHub Advisory Database · CC BY 4.0
- CVE-2018-8007 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences