Missing authorization in Apache Sentry
Priority MEDIUM 41CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
An authenticated user can execute ALTER TABLE EXCHANGE PARTITIONS without being authorized by Apache Sentry before 2.0.1. This can allow an attacker unauthorized access to the partitioned data of a Sentry protected table and can allow an attacker to remove data from a Sentry protected table.
Why it matters now
EPSS 0.0131 70th percentileScored 2026-11-07
Fix Fixed org.apache.sentry:sentry (Maven): 2.0.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Sentry | Apache Sentry 2.0.0 | — | No fix listed | CNA |
| — | org.apache.sentry:sentry (Maven) | before 2.0.1 | 2.0.1 | Patch available | GHSA-6xhj-p29v-82j8 |
- Apache Sentry VendorApache Affected Apache Sentry 2.0.0 Fixed in — No fix listed CNA
- org.apache.sentry:sentry (Maven) Vendor— Affected before 2.0.1 Fixed in 2.0.1 Patch available GHSA-6xhj-p29v-82j8
Remediation
- Fix · GHSA-6xhj-p29v-82j8 org.apache.sentry:sentry (Maven) Fixed in 2.0.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-8028
- 2026-10-03 Alias added: GHSA-6xhj-p29v-82j8
References
More Apache Sentry vulnerabilities
- TI-2016-00679 Multiple incomplete blacklist vulnerabilities in Apache Sentry before 1.7.0 allow remote… CVSS 3.0HIGH 8.8
Sources
- CVE-2018-8028 · CVE Program
- CVE-2018-8028 · NVD
- FIRST EPSS
- GHSA-6xhj-p29v-82j8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences