In the Loofah gem through 2.2.0 for Ruby, non-whitelisted HTML attributes may occur in…
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
In the Loofah gem through 2.2.0 for Ruby, non-whitelisted HTML attributes may occur in sanitized output by republishing a crafted HTML fragment.
Why it matters now
EPSS 0.01925 80th percentileScored 2026-11-07
Fix Fixed loofah (RubyGems): 2.2.1nokogiri (RubyGems): 1.8.3Red Hat: 1 advisory
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | loofah (RubyGems) | before 2.2.1 | 2.2.1 | Patch available | GHSA-x7rv-cr6v-4vm4 |
| — | nokogiri (RubyGems) | before 1.8.3 | 1.8.3 | Patch available | GHSA-x7rv-cr6v-4vm4 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- loofah (RubyGems) Vendor— Affected before 2.2.1 Fixed in 2.2.1 Patch available GHSA-x7rv-cr6v-4vm4
- nokogiri (RubyGems) Vendor— Affected before 1.8.3 Fixed in 1.8.3 Patch available GHSA-x7rv-cr6v-4vm4
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:a:loofah_project:loofah:*:*:*:*:*:ruby:*:* | before 2.2.1 | Vulnerable | flavorjones |
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:a:loofah_project:loofah:*:*:*:*:*:ruby:*:* Versions before 2.2.1 Vulnerable ·flavorjones
Remediation
- Fix · GHSA-x7rv-cr6v-4vm4 loofah (RubyGems) Fixed in 2.2.1 Advisory →
- Fix · GHSA-x7rv-cr6v-4vm4 nokogiri (RubyGems) Fixed in 1.8.3 Advisory →
Red Hat 1 advisory
- RHSA-2019:0212 Released 2019-02-07 · Red Hat rating ModerateCloudForms 4.7 security, bug fix and enhancement update
- CloudForms Management Engine 5.10 ansible-runner-1.1.2-2.el7ar, ansible-tower-3.3.3-1.el7at, ansible-tower-server-3.3.3-1.el7at +47
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| CloudForms Management Engine 5.10 | Fixed | RHSA-2019:0212 |
Not affected: 1 product
- Red Hat Software Collections
Timeline
- 2026-10-02 Threatist record created from CVE-2018-8048
- 2026-10-03 Alias added: GHSA-x7rv-cr6v-4vm4
References
Advisory 5
Other 7
- https://security.netapp.com/advisory/ntap-20191122-0003/
- https://github.com/sparklemotion/nokogiri/pull/1746
- https://github.com/flavorjones/loofah/commit/f739cf8eac5851f328b8044281d6653f74eff116
- https://github.com/flavorjones/loofah
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/loofah/CVE-2018-8048.yml
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/nokogiri/CVE-2018-8048.yml
- https://security.netapp.com/advisory/ntap-20191122-0003
Sources
- CVE-2018-8048 · CVE Program
- CVE-2018-8048 · NVD
- FIRST EPSS
- GHSA-x7rv-cr6v-4vm4 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-8048 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences