Yii 2.x before 2.0.15 allows remote attackers to inject unintended search conditions via…
Priority LOW 38CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Yii 2.x before 2.0.15 allows remote attackers to inject unintended search conditions via a variant of the CVE-2018-7269 attack in conjunction with the Elasticsearch extension.
Why it matters now
EPSS 0.01492 74th percentileScored 2026-11-07
Fix Fixed yiisoft/yii2-dev (Packagist): 2.0.15yiisoft/yii2-elasticsearch (Packagist): 2.0.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | yiisoft/yii2-dev (Packagist) | 2.0.0 to before 2.0.15 | 2.0.15 | Patch available | GHSA-m2p5-fwp2-qcw2 |
| — | yiisoft/yii2-elasticsearch (Packagist) | before 2.0.5 | 2.0.5 | Patch available | GHSA-m2p5-fwp2-qcw2 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- yiisoft/yii2-dev (Packagist) Vendor— Affected 2.0.0 to before 2.0.15 Fixed in 2.0.15 Patch available GHSA-m2p5-fwp2-qcw2
- yiisoft/yii2-elasticsearch (Packagist) Vendor— Affected before 2.0.5 Fixed in 2.0.5 Patch available GHSA-m2p5-fwp2-qcw2
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:yiiframework:yii:*:*:*:*:*:*:*:* | 2.0.0 to before 2.0.15 | Vulnerable | Yiiframework |
- cpe:2.3:a:yiiframework:yii:*:*:*:*:*:*:*:* Versions 2.0.0 to before 2.0.15 Vulnerable ·Yiiframework
Remediation
- Fix · GHSA-m2p5-fwp2-qcw2 yiisoft/yii2-dev (Packagist) Fixed in 2.0.15 Advisory →
- Fix · GHSA-m2p5-fwp2-qcw2 yiisoft/yii2-elasticsearch (Packagist) Fixed in 2.0.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-8074
- 2026-10-03 Alias added: GHSA-m2p5-fwp2-qcw2
References
Advisory 2
Other 4
- https://github.com/FriendsOfPHP/security-advisories/blob/master/yiisoft/yii2-elasticsearch/CVE-2018-8074.yaml
- https://github.com/yiisoft/yii2
- https://www.yiiframework.com/news/168/releasing-yii-2-0-15-and-database-extensions-with-security-fixes
- http://www.yiiframework.com/news/168/releasing-yii-2-0-15-and-database-extensions-with-security-fixes
More Yiiframework Yii vulnerabilities
- TI-2024-38344 Yii 2 before 2.0.52 mishandles the attaching of behavior that is defined by an __class… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-11920 Unsafe deserialization in Yii 2 CVSS 3.1CRITICAL 10.0
- TI-2024-04634 Unsafe Reflection in base Component class in yiisoft/yii2 CVSS 3.1CRITICAL 9.1
- TI-2025-02355 yiisoft Yii2 MockClass.php generate deserialization CVSS 4.0MEDIUM 5.3
- TI-2025-02354 yiisoft Yii2 SortableIterator.php getIterator deserialization CVSS 4.0MEDIUM 5.3
- TI-2023-11755 SQL injection vulnerability found in Yii Framework Yii 2 Framework before v.2.0.47 allows… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2018-8074 · CVE Program
- CVE-2018-8074 · NVD
- FIRST EPSS
- GHSA-m2p5-fwp2-qcw2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences