Weak password recovery in Synology DiskStation Manager
Priority MEDIUM 40CWE-620Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-640.
Summary
Unverified password change vulnerability in Change Password in Synology DiskStation Manager (DSM) before 6.2-23739 allows remote authenticated users to reset password without verification.
Why it matters now
EPSS 0.00977 62nd percentileScored 2026-11-07
Fix Fixed DiskStation Manager (DSM) (Synology): 6.2-23739
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA DiskStation Manager (DSM) (Synology) Fixed in 6.2-23739
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Synology DiskStation Manager (DSM) 6.2-23739
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2017-08869 Command injection in Synology DiskStation ManagerPriority LOW 35
Timeline
- 2026-10-02 Threatist record created from CVE-2018-8916
- 2026-10-03 Alias added: GHSA-4xw8-rvqf-qchf
References
More Synology Diskstation Manager vulnerabilities
- TI-2021-02242 Sudo before 1.9.5p2 contains an off-by-one error that can result in a heap-based buffer… KEVCVSS 3.1HIGH 7.8
- TI-2018-01076 Out-of-bounds write in Netatalk CVSS 3.1CRITICAL 9.8
- TI-2017-10594 Heap-based buffer overflow in dnsmasq before 2.78 allows remote attackers to cause a… CVSS 3.1CRITICAL 9.8
- TI-2013-05716 webman/imageSelector.cgi in Synology DiskStation Manager (DSM) 4.0 before 4.0-2259, 4.2… CVSS 2.0HIGH 10.0
- TI-2021-19843 Out-of-bounds read in Samba CVSS 3.1HIGH 8.8
- TI-2017-11636 Command injection in Synology DiskStation Manager CVSS 3.0HIGH 8.8
Sources
- CVE-2018-8916 · CVE Program
- CVE-2018-8916 · NVD
- FIRST EPSS
- GHSA-4xw8-rvqf-qchf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences