Read the docs
TI-2018-06694 Aliases CVE-2018-9243GHSA-7p8p-3gqp-fcqx

GitLab Community and Enterprise Editions version 8.4 up to 10.4 are vulnerable to XSS…

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

GitLab Community and Enterprise Editions version 8.4 up to 10.4 are vulnerable to XSS because a lack of input validation in the merge request component leads to cross site scripting (specifically, filenames in changes tabs of merge requests). This is fixed in 10.6.3, 10.5.7, and 10.4.7.

Why it matters now

EPSS 0.00983 62nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
  • — Vendor— Affected all versions Fixed in — No fix listed CNA

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:*8.4 to before 10.4.7VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*8.4 to before 10.4.7VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:*10.5.0 to before 10.5.7VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*10.5.0 to before 10.5.7VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:*10.6.0 to before 10.6.3VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*10.6.0 to before 10.6.3VulnerableGitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 8.4 to before 10.4.7 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 8.4 to before 10.4.7 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 10.5.0 to before 10.5.7 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 10.5.0 to before 10.5.7 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 10.6.0 to before 10.6.3 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 10.6.0 to before 10.6.3 Vulnerable ·GitLab

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-9243
  2. 2026-10-03 Alias added: GHSA-7p8p-3gqp-fcqx

References

  • TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
  • TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
  • TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
  • TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
  • TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
  • TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
See all 1506 →

Sources