Kotti before 1.3.2 and 2.x before 2.0.0b2 has CSRF in the local roles implementation, as…
Priority LOW 39CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
Kotti before 1.3.2 and 2.x before 2.0.0b2 has CSRF in the local roles implementation, as demonstrated by triggering a permission change via a /admin-document/@@share request.
Why it matters now
EPSS 0.00633 50th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Kotti (PyPI): 1.3.2, 2.0.0b2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Kotti (PyPI) | before 1.3.2 | 1.3.2 | Patch available | GHSA-3hq4-f2v6-q338 |
| — | Kotti (PyPI) | 2.0.0a1 to before 2.0.0b2 | 2.0.0b2 | Patch available | GHSA-3hq4-f2v6-q338 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Kotti (PyPI) Vendor— Affected before 1.3.2 Fixed in 1.3.2 Patch available GHSA-3hq4-f2v6-q338
- Kotti (PyPI) Vendor— Affected 2.0.0a1 to before 2.0.0b2 Fixed in 2.0.0b2 Patch available GHSA-3hq4-f2v6-q338
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:kotti_project:kotti:*:*:*:*:*:*:*:* | before 1.3.2 | Vulnerable | Kotti Project |
| cpe:2.3:a:kotti_project:kotti:2.0.0:alpha1:*:*:*:*:*:* | 2.0.0 alpha1 | Vulnerable | Kotti Project |
| cpe:2.3:a:kotti_project:kotti:2.0.0b1:*:*:*:*:*:*:* | 2.0.0b1 | Vulnerable | Kotti Project |
- cpe:2.3:a:kotti_project:kotti:*:*:*:*:*:*:*:* Versions before 1.3.2 Vulnerable ·Kotti Project
- cpe:2.3:a:kotti_project:kotti:2.0.0:alpha1:*:*:*:*:*:* Versions 2.0.0 alpha1 Vulnerable ·Kotti Project
- cpe:2.3:a:kotti_project:kotti:2.0.0b1:*:*:*:*:*:*:* Versions 2.0.0b1 Vulnerable ·Kotti Project
Remediation
- Fix · GHSA-3hq4-f2v6-q338 Kotti (PyPI) Fixed in 1.3.2 Advisory →
- Fix · GHSA-3hq4-f2v6-q338 Kotti (PyPI) Fixed in 2.0.0b2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-9856
- 2026-10-03 Alias added: GHSA-3hq4-f2v6-q338
- 2026-10-25 EPSS moved to the 50th–90th percentile
References
Advisory 2
Sources
- CVE-2018-9856 · CVE Program
- CVE-2018-9856 · NVD
- FIRST EPSS
- GHSA-3hq4-f2v6-q338 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences