Cross-site scripting (XSS) vulnerability in the Enhanced Image (aka image2) plugin for…
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the Enhanced Image (aka image2) plugin for CKEditor (in versions 4.5.10 through 4.9.1; fixed in 4.9.2), as used in Drupal 8 before 8.4.7 and 8.5.x before 8.5.2 and other products, allows remote attackers to inject arbitrary web script through a crafted IMG element.
Why it matters now
EPSS 0.01719 77th percentileScored 2026-11-07
Fix Fixed drupal/core (Packagist): 8.5.2, 8.4.7ckeditor-dev (npm): 4.9.2+1 more product
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | drupal/core (Packagist) | 8.5.0 to before 8.5.2 | 8.5.2 | Patch available | GHSA-g78h-pf65-46rv |
| — | ckeditor-dev (npm) | 4.5.10 to before 4.9.2 | 4.9.2 | Patch available | GHSA-g78h-pf65-46rv |
| — | drupal/core (Packagist) | 8.0 to before 8.4.7 | 8.4.7 | Patch available | GHSA-g78h-pf65-46rv |
| — | drupal/drupal (Packagist) | 8.0 to before 8.4.7 | 8.4.7 | Patch available | GHSA-g78h-pf65-46rv |
| — | drupal/drupal (Packagist) | 8.5 to before 8.5.2 | 8.5.2 | Patch available | GHSA-g78h-pf65-46rv |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- drupal/core (Packagist) Vendor— Affected 8.5.0 to before 8.5.2 Fixed in 8.5.2 Patch available GHSA-g78h-pf65-46rv
- ckeditor-dev (npm) Vendor— Affected 4.5.10 to before 4.9.2 Fixed in 4.9.2 Patch available GHSA-g78h-pf65-46rv
- drupal/core (Packagist) Vendor— Affected 8.0 to before 8.4.7 Fixed in 8.4.7 Patch available GHSA-g78h-pf65-46rv
- drupal/drupal (Packagist) Vendor— Affected 8.0 to before 8.4.7 Fixed in 8.4.7 Patch available GHSA-g78h-pf65-46rv
- drupal/drupal (Packagist) Vendor— Affected 8.5 to before 8.5.2 Fixed in 8.5.2 Patch available GHSA-g78h-pf65-46rv
Remediation
- Fix · GHSA-g78h-pf65-46rv drupal/core (Packagist) Fixed in 8.5.2 Advisory →
- Fix · GHSA-g78h-pf65-46rv ckeditor-dev (npm) Fixed in 4.9.2 Advisory →
- Fix · GHSA-g78h-pf65-46rv drupal/core (Packagist) Fixed in 8.4.7 Advisory →
- Fix · GHSA-g78h-pf65-46rv drupal/drupal (Packagist) Fixed in 8.4.7 Advisory →
- Fix · GHSA-g78h-pf65-46rv drupal/drupal (Packagist) Fixed in 8.5.2 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2018-9861
- 2026-10-03 Alias added: GHSA-g78h-pf65-46rv
References
Other 4
- https://github.com/ckeditor/ckeditor-dev/blob/master/CHANGES.md
- https://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/core/CVE-2018-9861.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/drupal/CVE-2018-9861.yaml
Sources
- CVE-2018-9861 · CVE Program
- CVE-2018-9861 · NVD
- FIRST EPSS
- GHSA-g78h-pf65-46rv · GitHub Advisory Database · CC BY 4.0
- CVE-2018-9861 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences