Improper input validation in Samsung Galaxy Apps
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA.
Summary
This vulnerability allows local attackers to execute arbitrary code on vulnerable installations of Samsung Galaxy Apps Fixed in version 6.4.0.15. An attacker must first obtain the ability to execute low-privileged code on the target system in order to exploit this vulnerability. The specific flaw exists within the handling of URLs. The issue lies in the lack of proper validation of user-supplied data, which can allow arbitrary JavaScript to execute. An attacker can leverage this vulnerability to install applications under the context of the current user. Was ZDI-CAN-5330.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2018-10499
- 2026-10-03 Alias added: GHSA-qqc6-9r93-rfgq
References
More Samsung Galaxy Apps vulnerabilities
- TI-2018-14262 Samsung Galaxy Apps before 4.4.01.7 allows modification of the hostname used for load… CVSS 3.0HIGH 8.1
- TI-2018-07411 Improper privilege management in Samsung Galaxy Apps CVSS 3.0HIGH 7.8
- TI-2018-07409 Improper access control in Samsung Galaxy Apps CVSS 3.0HIGH 7.0
Sources
- CVE-2018-10499 · CVE Program
- CVE-2018-10499 · NVD
- FIRST EPSS
- GHSA-qqc6-9r93-rfgq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences