Cross-site request forgery in qutebrowser cross-site request forgery flaw allows sites to…
Priority MEDIUM 42CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
qutebrowser before version 1.4.1 is vulnerable to a cross-site request forgery flaw that allows websites to access 'qute://*' URLs. A malicious website could exploit this to load a 'qute://settings/set' URL, which then sets 'editor.command' to a bash script, resulting in arbitrary code execution.
Why it matters now
EPSS 0.01198 68th percentileScored 2026-11-07
Fix Fixed qutebrowser (PyPI): 1.4.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| qutebrowser | cross-site request forgery flaw allows sites to access 'qute | qutebrowser 1.4.1 | — | No fix listed | CNA |
| — | qutebrowser (PyPI) | before 1.4.1 | 1.4.1 | Patch available | GHSA-wgmx-52ph-qqcw |
- cross-site request forgery flaw allows sites to access 'qute Vendorqutebrowser Affected qutebrowser 1.4.1 Fixed in — No fix listed CNA
- qutebrowser (PyPI) Vendor— Affected before 1.4.1 Fixed in 1.4.1 Patch available GHSA-wgmx-52ph-qqcw
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:qutebrowser:qutebrowser:*:*:*:*:*:*:*:* | before 1.4.1 | Vulnerable | qutebrowser |
- cpe:2.3:a:qutebrowser:qutebrowser:*:*:*:*:*:*:*:* Versions before 1.4.1 Vulnerable ·qutebrowser
Remediation
- Fix · GHSA-wgmx-52ph-qqcw qutebrowser (PyPI) Fixed in 1.4.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2018-10895
- 2026-10-03 Alias added: GHSA-wgmx-52ph-qqcw
References
Patch 3
More Qutebrowser vulnerabilities
- TI-2021-17985 Arbitrary command execution on Windows in qutebrowser CVSS 3.1HIGH 8.8
- TI-2018-15954 qutebrowser version introduced in v0.11.0 (1179ee7a937fb31414d77d9970bac21095358449)… CVSS 3.0MEDIUM 6.1
- TI-2020-08928 Incorrect Provision of Specified Functionality in qutebrowser CVSS 3.1LOW 3.5
Sources
- CVE-2018-10895 · CVE Program
- CVE-2018-10895 · NVD
- FIRST EPSS
- GHSA-wgmx-52ph-qqcw · GitHub Advisory Database · CC BY 4.0
- CVE-2018-10895 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences