Read the docs
TI-2018-07716 Aliases CVE-2018-10903GHSA-fcf9-3qw3-gxmj

Improper input validation in [UNKNOWN] python-cryptography

Priority LOW 39CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · None · None
Fix status
Partial Red Hat: 1 fixed, 1 without a fix

Attack profile from CVSS 3.0 · CNA. Fix status from CNA, GitHub and Red Hat.

Summary

A flaw was found in python-cryptography versions between >=1.9.0 and <2.3. The finalize_with_tag API did not enforce a minimum tag length. If a user did not validate the input length prior to passing it to finalize_with_tag an attacker could craft an invalid payload with a shortened tag (e.g. 1 byte) such that they would have a 1 in 256 chance of passing the MAC check. GCM tag forgeries can cause key leakage.

Why it matters now

EPSS 0.03196 88th percentileScored 2026-11-07
Fix Partial cryptography (PyPI): 2.3Red Hat: 1 advisoryRed Hat: 1 fixed, 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
[UNKNOWN]python-cryptography2.3—No fix listedCNA
—cryptography (PyPI)1.9.0 to before 2.32.3Patch availableGHSA-fcf9-3qw3-gxmj
  • python-cryptography Vendor[UNKNOWN] Affected 2.3 Fixed in — No fix listed CNA
  • cryptography (PyPI) Vendor— Affected 1.9.0 to before 2.3 Fixed in 2.3 Patch available GHSA-fcf9-3qw3-gxmj

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:cryptography:python-cryptography:*:*:*:*:*:*:*:*1.9.0 to before 2.3VulnerableCryptography
cpe:2.3:a:redhat:openstack:13:*:*:*:*:*:*:*13VulnerableRed Hat
cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*18.04VulnerableCanonical
  • cpe:2.3:a:cryptography:python-cryptography:*:*:*:*:*:*:*:* Versions 1.9.0 to before 2.3 Vulnerable ·Cryptography
  • cpe:2.3:a:redhat:openstack:13:*:*:*:*:*:*:* Versions 13 Vulnerable ·Red Hat
  • cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical

Remediation

  • Fix · GHSA-fcf9-3qw3-gxmj cryptography (PyPI) Fixed in 2.3 Advisory →

Red Hat 1 advisory

  • RHSA-2018:3600 Released 2018-11-13 · Red Hat rating Moderate
    python-cryptography security update
    • Red Hat OpenStack Platform 13.0 python-cryptography-2.1.4-3.el7ost, python2-cryptography-2.1.4-3.el7ost

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenStack Platform 14 (Rocky)AffectedNo fix yet
Red Hat OpenStack Platform 13.0Fixed RHSA-2018:3600
Not affected: 6 products
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux OpenStack Platform 7 (Kilo)
  • Red Hat OpenStack Platform 8 (Liberty)
  • Red Hat OpenStack Platform 9 (Mitaka)
  • Red Hat Virtualization 4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-10903
  2. 2026-10-03 Alias added: GHSA-fcf9-3qw3-gxmj

References

Sources