Cross-site scripting (XSS) vulnerability in the Link package for CKEditor 5 before 10.0.1…
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the Link package for CKEditor 5 before 10.0.1 allows remote attackers to inject arbitrary web script through a crafted href attribute of a link (A) element.
Why it matters now
EPSS 0.00997 62nd percentileScored 2026-11-07
Fix Fixed @ckeditor/ckeditor5-link (npm): 10.0.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | @ckeditor/ckeditor5-link (npm) | 0.3.0 to before 10.0.1 | 10.0.1 | Patch available | GHSA-gvpx-9459-w3mj |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- @ckeditor/ckeditor5-link (npm) Vendor— Affected 0.3.0 to before 10.0.1 Fixed in 10.0.1 Patch available GHSA-gvpx-9459-w3mj
Remediation
- Fix · GHSA-gvpx-9459-w3mj @ckeditor/ckeditor5-link (npm) Fixed in 10.0.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-11093
- 2026-10-03 Alias added: GHSA-gvpx-9459-w3mj
References
Advisory 4
Sources
- CVE-2018-11093 · CVE Program
- CVE-2018-11093 · NVD
- FIRST EPSS
- GHSA-gvpx-9459-w3mj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences