Read the docs
TI-2018-08124 Aliases CVE-2018-11385GHSA-g4rg-rw65-8hfg

An issue was discovered in the Security component in Symfony 2.7.x before 2.7.48, 2.8.x…

Priority LOW 39CWE-384Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Spoofing
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-384.

Summary

An issue was discovered in the Security component in Symfony 2.7.x before 2.7.48, 2.8.x before 2.8.41, 3.3.x before 3.3.17, 3.4.x before 3.4.11, and 4.0.x before 4.0.11. A session fixation vulnerability within the "Guard" login feature may allow an attacker to impersonate a victim towards the web application if the session id value was previously known to the attacker.

Why it matters now

EPSS 0.01974 80th percentileScored 2026-11-07
Fix Fixed symfony/symfony (Packagist): 2.7.48, 2.8.41, 3.3.17 +2symfony/security-http (Packagist): 2.7.48, 2.8.41, 3.3.17 +2+1 more product

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—symfony/symfony (Packagist)2.7.0 to before 2.7.482.7.48Patch availableGHSA-g4rg-rw65-8hfg
—symfony/symfony (Packagist)2.8.0 to before 2.8.412.8.41Patch availableGHSA-g4rg-rw65-8hfg
—symfony/symfony (Packagist)3.0.0 to before 3.3.173.3.17Patch availableGHSA-g4rg-rw65-8hfg
—symfony/symfony (Packagist)3.4.0 to before 3.4.113.4.11Patch availableGHSA-g4rg-rw65-8hfg
—symfony/symfony (Packagist)4.0.0 to before 4.0.114.0.11Patch availableGHSA-g4rg-rw65-8hfg
—symfony/security-http (Packagist)2.7.0 to before 2.7.482.7.48Patch availableGHSA-g4rg-rw65-8hfg
—symfony/security-http (Packagist)2.8.0 to before 2.8.412.8.41Patch availableGHSA-g4rg-rw65-8hfg
—symfony/security-http (Packagist)3.0.0 to before 3.3.173.3.17Patch availableGHSA-g4rg-rw65-8hfg
—symfony/security-http (Packagist)3.4.0 to before 3.4.113.4.11Patch availableGHSA-g4rg-rw65-8hfg
—symfony/security-http (Packagist)4.0.0 to before 4.0.114.0.11Patch availableGHSA-g4rg-rw65-8hfg
—symfony/security (Packagist)2.7.0 to before 2.7.482.7.48Patch availableGHSA-g4rg-rw65-8hfg
—symfony/security (Packagist)2.8.0 to before 2.8.412.8.41Patch availableGHSA-g4rg-rw65-8hfg
—symfony/security (Packagist)3.0.0 to before 3.3.173.3.17Patch availableGHSA-g4rg-rw65-8hfg
—symfony/security (Packagist)3.4.0 to before 3.4.113.4.11Patch availableGHSA-g4rg-rw65-8hfg
—symfony/security (Packagist)4.0.0 to before 4.0.114.0.11Patch availableGHSA-g4rg-rw65-8hfg
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • symfony/symfony (Packagist) Vendor— Affected 2.7.0 to before 2.7.48 Fixed in 2.7.48 Patch available GHSA-g4rg-rw65-8hfg
  • symfony/symfony (Packagist) Vendor— Affected 2.8.0 to before 2.8.41 Fixed in 2.8.41 Patch available GHSA-g4rg-rw65-8hfg
  • symfony/symfony (Packagist) Vendor— Affected 3.0.0 to before 3.3.17 Fixed in 3.3.17 Patch available GHSA-g4rg-rw65-8hfg
  • symfony/symfony (Packagist) Vendor— Affected 3.4.0 to before 3.4.11 Fixed in 3.4.11 Patch available GHSA-g4rg-rw65-8hfg
  • symfony/symfony (Packagist) Vendor— Affected 4.0.0 to before 4.0.11 Fixed in 4.0.11 Patch available GHSA-g4rg-rw65-8hfg
  • symfony/security-http (Packagist) Vendor— Affected 2.7.0 to before 2.7.48 Fixed in 2.7.48 Patch available GHSA-g4rg-rw65-8hfg
  • symfony/security-http (Packagist) Vendor— Affected 2.8.0 to before 2.8.41 Fixed in 2.8.41 Patch available GHSA-g4rg-rw65-8hfg
  • symfony/security-http (Packagist) Vendor— Affected 3.0.0 to before 3.3.17 Fixed in 3.3.17 Patch available GHSA-g4rg-rw65-8hfg
  • symfony/security-http (Packagist) Vendor— Affected 3.4.0 to before 3.4.11 Fixed in 3.4.11 Patch available GHSA-g4rg-rw65-8hfg
  • symfony/security-http (Packagist) Vendor— Affected 4.0.0 to before 4.0.11 Fixed in 4.0.11 Patch available GHSA-g4rg-rw65-8hfg
  • symfony/security (Packagist) Vendor— Affected 2.7.0 to before 2.7.48 Fixed in 2.7.48 Patch available GHSA-g4rg-rw65-8hfg
  • symfony/security (Packagist) Vendor— Affected 2.8.0 to before 2.8.41 Fixed in 2.8.41 Patch available GHSA-g4rg-rw65-8hfg
  • symfony/security (Packagist) Vendor— Affected 3.0.0 to before 3.3.17 Fixed in 3.3.17 Patch available GHSA-g4rg-rw65-8hfg
  • symfony/security (Packagist) Vendor— Affected 3.4.0 to before 3.4.11 Fixed in 3.4.11 Patch available GHSA-g4rg-rw65-8hfg
  • symfony/security (Packagist) Vendor— Affected 4.0.0 to before 4.0.11 Fixed in 4.0.11 Patch available GHSA-g4rg-rw65-8hfg

CPE configurations NVD · 4

CPEVersionsRoleVendor
cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:*2.7.0 to before 2.7.48; 2.8.0 to before 2.8.41; 3.3.0 to before 3.3.17; 3.4.0 to before 3.4.11; 4.0.0 to before 4.0.11Vulnerablesensiolabs
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*8.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
cpe:2.3:o:fedoraproject:fedora:28:*:*:*:*:*:*:*28VulnerableFedoraproject
  • cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* Versions 2.7.0 to before 2.7.48; 2.8.0 to before 2.8.41; 3.3.0 to before 3.3.17; 3.4.0 to before 3.4.11; 4.0.0 to before 4.0.11 Vulnerable ·sensiolabs
  • cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
  • cpe:2.3:o:fedoraproject:fedora:28:*:*:*:*:*:*:* Versions 28 Vulnerable ·Fedoraproject

Remediation

  • Fix · GHSA-g4rg-rw65-8hfg symfony/symfony (Packagist) Fixed in 2.7.48 Advisory →
  • Fix · GHSA-g4rg-rw65-8hfg symfony/symfony (Packagist) Fixed in 2.8.41 Advisory →
  • Fix · GHSA-g4rg-rw65-8hfg symfony/symfony (Packagist) Fixed in 3.3.17 Advisory →
  • Fix · GHSA-g4rg-rw65-8hfg symfony/symfony (Packagist) Fixed in 3.4.11 Advisory →
  • Fix · GHSA-g4rg-rw65-8hfg symfony/symfony (Packagist) Fixed in 4.0.11 Advisory →
  • Fix · GHSA-g4rg-rw65-8hfg symfony/security-http (Packagist) Fixed in 2.7.48 Advisory →
  • Fix · GHSA-g4rg-rw65-8hfg symfony/security-http (Packagist) Fixed in 2.8.41 Advisory →
  • Fix · GHSA-g4rg-rw65-8hfg symfony/security-http (Packagist) Fixed in 3.3.17 Advisory →
  • Fix · GHSA-g4rg-rw65-8hfg symfony/security-http (Packagist) Fixed in 3.4.11 Advisory →
  • Fix · GHSA-g4rg-rw65-8hfg symfony/security-http (Packagist) Fixed in 4.0.11 Advisory →
  • Fix · GHSA-g4rg-rw65-8hfg symfony/security (Packagist) Fixed in 2.7.48 Advisory →
  • Fix · GHSA-g4rg-rw65-8hfg symfony/security (Packagist) Fixed in 2.8.41 Advisory →
  • Fix · GHSA-g4rg-rw65-8hfg symfony/security (Packagist) Fixed in 3.3.17 Advisory →
  • Fix · GHSA-g4rg-rw65-8hfg symfony/security (Packagist) Fixed in 3.4.11 Advisory →
  • Fix · GHSA-g4rg-rw65-8hfg symfony/security (Packagist) Fixed in 4.0.11 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-11385
  2. 2026-10-03 Alias added: GHSA-g4rg-rw65-8hfg

References

Sources