The security handlers in the Security component in Symfony in 2.7.x before 2.7.48, 2.8.x…
Priority LOW 29CWE-601Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-601.
Summary
The security handlers in the Security component in Symfony in 2.7.x before 2.7.48, 2.8.x before 2.8.41, 3.3.x before 3.3.17, 3.4.x before 3.4.11, and 4.0.x before 4.0.11 have an Open redirect vulnerability when security.http_utils is inlined by a container. NOTE: this issue exists because of an incomplete fix for CVE-2017-16652.
Why it matters now
EPSS 0.01121 66th percentileScored 2026-11-07
Fix Fixed symfony/symfony (Packagist): 2.7.48, 2.8.41, 3.3.17 +2symfony/security-bundle (Packagist): 2.7.48, 2.8.41, 3.3.17 +2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | symfony/symfony (Packagist) | 2.7.0 to before 2.7.48 | 2.7.48 | Patch available | GHSA-7hwc-2cq4-6x2w |
| — | symfony/symfony (Packagist) | 2.8.0 to before 2.8.41 | 2.8.41 | Patch available | GHSA-7hwc-2cq4-6x2w |
| — | symfony/symfony (Packagist) | 3.3.0 to before 3.3.17 | 3.3.17 | Patch available | GHSA-7hwc-2cq4-6x2w |
| — | symfony/symfony (Packagist) | 3.4.0 to before 3.4.11 | 3.4.11 | Patch available | GHSA-7hwc-2cq4-6x2w |
| — | symfony/symfony (Packagist) | 4.0.0 to before 4.0.11 | 4.0.11 | Patch available | GHSA-7hwc-2cq4-6x2w |
| — | symfony/security-bundle (Packagist) | 2.7.0 to before 2.7.48 | 2.7.48 | Patch available | GHSA-7hwc-2cq4-6x2w |
| — | symfony/security-bundle (Packagist) | 2.8.0 to before 2.8.41 | 2.8.41 | Patch available | GHSA-7hwc-2cq4-6x2w |
| — | symfony/security-bundle (Packagist) | 3.3.0 to before 3.3.17 | 3.3.17 | Patch available | GHSA-7hwc-2cq4-6x2w |
| — | symfony/security-bundle (Packagist) | 3.4.0 to before 3.4.11 | 3.4.11 | Patch available | GHSA-7hwc-2cq4-6x2w |
| — | symfony/security-bundle (Packagist) | 4.0.0 to before 4.0.11 | 4.0.11 | Patch available | GHSA-7hwc-2cq4-6x2w |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- symfony/symfony (Packagist) Vendor— Affected 2.7.0 to before 2.7.48 Fixed in 2.7.48 Patch available GHSA-7hwc-2cq4-6x2w
- symfony/symfony (Packagist) Vendor— Affected 2.8.0 to before 2.8.41 Fixed in 2.8.41 Patch available GHSA-7hwc-2cq4-6x2w
- symfony/symfony (Packagist) Vendor— Affected 3.3.0 to before 3.3.17 Fixed in 3.3.17 Patch available GHSA-7hwc-2cq4-6x2w
- symfony/symfony (Packagist) Vendor— Affected 3.4.0 to before 3.4.11 Fixed in 3.4.11 Patch available GHSA-7hwc-2cq4-6x2w
- symfony/symfony (Packagist) Vendor— Affected 4.0.0 to before 4.0.11 Fixed in 4.0.11 Patch available GHSA-7hwc-2cq4-6x2w
- symfony/security-bundle (Packagist) Vendor— Affected 2.7.0 to before 2.7.48 Fixed in 2.7.48 Patch available GHSA-7hwc-2cq4-6x2w
- symfony/security-bundle (Packagist) Vendor— Affected 2.8.0 to before 2.8.41 Fixed in 2.8.41 Patch available GHSA-7hwc-2cq4-6x2w
- symfony/security-bundle (Packagist) Vendor— Affected 3.3.0 to before 3.3.17 Fixed in 3.3.17 Patch available GHSA-7hwc-2cq4-6x2w
- symfony/security-bundle (Packagist) Vendor— Affected 3.4.0 to before 3.4.11 Fixed in 3.4.11 Patch available GHSA-7hwc-2cq4-6x2w
- symfony/security-bundle (Packagist) Vendor— Affected 4.0.0 to before 4.0.11 Fixed in 4.0.11 Patch available GHSA-7hwc-2cq4-6x2w
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* | 2.7.0 to before 2.7.48; 2.8.0 to before 2.8.41; 3.3.0 to before 3.3.17; 3.4.0 to before 3.4.11; 4.0.0 to before 4.0.11 | Vulnerable | sensiolabs |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
- cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* Versions 2.7.0 to before 2.7.48; 2.8.0 to before 2.8.41; 3.3.0 to before 3.3.17; 3.4.0 to before 3.4.11; 4.0.0 to before 4.0.11 Vulnerable ·sensiolabs
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-7hwc-2cq4-6x2w symfony/symfony (Packagist) Fixed in 2.7.48 Advisory →
- Fix · GHSA-7hwc-2cq4-6x2w symfony/symfony (Packagist) Fixed in 2.8.41 Advisory →
- Fix · GHSA-7hwc-2cq4-6x2w symfony/symfony (Packagist) Fixed in 3.3.17 Advisory →
- Fix · GHSA-7hwc-2cq4-6x2w symfony/symfony (Packagist) Fixed in 3.4.11 Advisory →
- Fix · GHSA-7hwc-2cq4-6x2w symfony/symfony (Packagist) Fixed in 4.0.11 Advisory →
- Fix · GHSA-7hwc-2cq4-6x2w symfony/security-bundle (Packagist) Fixed in 2.7.48 Advisory →
- Fix · GHSA-7hwc-2cq4-6x2w symfony/security-bundle (Packagist) Fixed in 2.8.41 Advisory →
- Fix · GHSA-7hwc-2cq4-6x2w symfony/security-bundle (Packagist) Fixed in 3.3.17 Advisory →
- Fix · GHSA-7hwc-2cq4-6x2w symfony/security-bundle (Packagist) Fixed in 3.4.11 Advisory →
- Fix · GHSA-7hwc-2cq4-6x2w symfony/security-bundle (Packagist) Fixed in 4.0.11 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2018-11408
- 2026-10-03 Alias added: GHSA-7hwc-2cq4-6x2w
References
Advisory 6
Other 8
- https://github.com/symfony/symfony/commit/b20e83562e32c56f8d9b8296ab07b0e4c0a54db8
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/security-bundle/CVE-2018-11408.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2018-11408.yaml
- https://github.com/symfony/symfony
- https://lists.fedoraproject.org/archives/list/[email protected]/message/G4XNBMFW33H47O5TZGA7JYCVLDBCXAJV
- https://lists.fedoraproject.org/archives/list/[email protected]/message/UBQK7JDXIELADIPGZIOUCZKMAJM5LSBW
- https://lists.fedoraproject.org/archives/list/[email protected]/message/WU5N2TZFNGXDGMXMPP7LZCWTFLENF6WH
- https://symfony.com/cve-2018-11408
Sources
- CVE-2018-11408 · CVE Program
- CVE-2018-11408 · NVD
- FIRST EPSS
- GHSA-7hwc-2cq4-6x2w · GitHub Advisory Database · CC BY 4.0
- CVE-2018-11408 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences