Read the docs
TI-2018-08303 Aliases CVE-2018-11615GHSA-wqg7-vrj7-v82h

Improper input validation in npm mosca

Priority LOW 39CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.

Summary

This vulnerability allows remote attackers to deny service on vulnerable installations of npm mosca 2.8.1. Authentication is not required to exploit this vulnerability. The specific flaw exists within the processing of topics. A crafted regular expression can cause the broker to crash. An attacker can leverage this vulnerability to deny access to the target system. Was ZDI-CAN-6306.

Why it matters now

EPSS 0.03219 88th percentileScored 2026-11-07
Fix Fixed mosca (npm): 2.8.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
npmnpm mosca2.8.1—No fix listedCNA
—mosca (npm)before 2.8.22.8.2Patch availableGHSA-wqg7-vrj7-v82h
  • npm mosca Vendornpm Affected 2.8.1 Fixed in — No fix listed CNA
  • mosca (npm) Vendor— Affected before 2.8.2 Fixed in 2.8.2 Patch available GHSA-wqg7-vrj7-v82h

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:mosca_project:mosca:2.8.1:*:*:*:*:node.js:*:*2.8.1VulnerableMosca Project
  • cpe:2.3:a:mosca_project:mosca:2.8.1:*:*:*:*:node.js:*:* Versions 2.8.1 Vulnerable ·Mosca Project

Remediation

  • Fix · GHSA-wqg7-vrj7-v82h mosca (npm) Fixed in 2.8.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-11615
  2. 2026-10-03 Alias added: GHSA-wqg7-vrj7-v82h

References

Sources