When using PySpark , it's possible for a different local user to connect to the Spark…
Priority LOW 26Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
When using PySpark , it's possible for a different local user to connect to the Spark application and impersonate the user running the Spark application. This affects versions 1.x, 2.0.x, 2.1.x, 2.2.0 to 2.2.2, and 2.3.0 to 2.3.1.
Why it matters now
EPSS 0.00605 49th percentileScored 2026-11-07
Fix Partial pyspark (PyPI): 2.3.2, 2.2.3Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Spark | Apache Spark 1.x, 2.0.x, 2.1.x, 2.2.0 to 2.2.2, and 2.3.0 to 2.3.1 | — | No fix listed | CNA |
| — | pyspark (PyPI) | 2.3.0 to before 2.3.2 | 2.3.2 | Patch available | GHSA-fvxv-9xxr-h7wj |
| — | pyspark (PyPI) | 1.0.2 to before 2.2.3 | 2.2.3 | Patch available | GHSA-fvxv-9xxr-h7wj |
- Apache Spark VendorApache Affected Apache Spark 1.x, 2.0.x, 2.1.x, 2.2.0 to 2.2.2, and 2.3.0 to 2.3.1 Fixed in — No fix listed CNA
- pyspark (PyPI) Vendor— Affected 2.3.0 to before 2.3.2 Fixed in 2.3.2 Patch available GHSA-fvxv-9xxr-h7wj
- pyspark (PyPI) Vendor— Affected 1.0.2 to before 2.2.3 Fixed in 2.2.3 Patch available GHSA-fvxv-9xxr-h7wj
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:spark:*:*:*:*:*:*:*:* | 1.0.2 – 1.6.3; 2.0.0 – 2.0.2; 2.1.0 – 2.1.3; 2.2.0 – 2.2.2; 2.3.0 – 2.3.1 | Vulnerable | Apache |
- cpe:2.3:a:apache:spark:*:*:*:*:*:*:*:* Versions 1.0.2 – 1.6.3; 2.0.0 – 2.0.2; 2.1.0 – 2.1.3; 2.2.0 – 2.2.2; 2.3.0 – 2.3.1 Vulnerable ·Apache
Remediation
- Fix · GHSA-fvxv-9xxr-h7wj pyspark (PyPI) Fixed in 2.3.2 Advisory →
- Fix · GHSA-fvxv-9xxr-h7wj pyspark (PyPI) Fixed in 2.2.3 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat JBoss Fuse 6 | Affected | No fix planned: Out of support scope |
Not affected: 1 product
- Red Hat Fuse 7
Timeline
- 2026-10-02 Threatist record created from CVE-2018-11760
- 2026-10-03 Alias added: GHSA-fvxv-9xxr-h7wj
References
Advisory 2
Other 8
- [[email protected]] 20190128 [SECURITY] CVE-2018-11760: Apache Spark local privilege escalation vulnerability
- [spark-commits] 20190806 [spark-website] branch asf-site updated: CVE-2019-10099
- https://github.com/apache/spark
- https://github.com/pypa/advisory-database/tree/main/vulns/pyspark/PYSEC-2019-169.yaml
- https://lists.apache.org/thread.html/6d015e56b3a3da968f86e0b6acc69f17ecc16b499389e12d8255bf6e@%3Ccommits.spark.apache.org%3E
- https://lists.apache.org/thread.html/a86ee93d07b6f61b82b61a28049aed311f5cc9420d26cc95f1a9de7b@%3Cuser.spark.apache.org%3E
- https://web.archive.org/web/20200227091119/http://www.securityfocus.com/bid/106786
- https://web.archive.org/web/20200925111106/https://issues.apache.org/jira/browse/SPARK-26802
More Apache Spark vulnerabilities
- TI-2022-14901 Apache Spark shell command injection vulnerability via Spark UI KEVCVSS 3.1HIGH 8.8
- TI-2023-15314 Apache Spark: Shell command injection via Spark UI CVSS 3.1HIGH 8.8
- TI-2020-07589 Missing authentication in Apache Spark CVSS 3.1CRITICAL 9.8
- TI-2020-16549 Uncontrolled resource consumption in Eclipse Jetty CVSS 3.1MEDIUM 5.3
- TI-2019-14677 HttpObjectDecoder.java in Netty before 4.1.44 allows a Content-Length header to be… CVSS 3.1CRITICAL 9.1
- TI-2018-08427 Improper authentication in Apache Spark CVSS 3.1MEDIUM 4.2
Sources
- CVE-2018-11760 · CVE Program
- CVE-2018-11760 · NVD
- FIRST EPSS
- GHSA-fvxv-9xxr-h7wj · GitHub Advisory Database · CC BY 4.0
- CVE-2018-11760 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences