Improper input validation in Apache Struts
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.
Summary
Apache Struts versions 2.3 to 2.3.34 and 2.5 to 2.5.16 suffer from possible Remote Code Execution when alwaysSelectFullNamespace is true (either by user or a plugin like Convention Plugin) and then: results are used with no namespace and in same time, its upper package have no or wildcard namespace and similar to results, same possibility when using url tag which doesn't have value and action set and in same time, its upper package have no or wildcard namespace.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Struts | 2.3 to 2.3.34; 2.5 to 2.5.16 | — | No fix listed | CNA |
| — | org.apache.struts:struts2-core (Maven) | 2.0.4 to before 2.3.35 | 2.3.35 | Patch available | GHSA-cr6j-3jp9-rw65 |
| — | org.apache.struts:struts2-core (Maven) | 2.5 to before 2.5.17 | 2.5.17 | Patch available | GHSA-cr6j-3jp9-rw65 |
- Apache Struts VendorApache Affected 2.3 to 2.3.34; 2.5 to 2.5.16 Fixed in — No fix listed CNA
- org.apache.struts:struts2-core (Maven) Vendor— Affected 2.0.4 to before 2.3.35 Fixed in 2.3.35 Patch available GHSA-cr6j-3jp9-rw65
- org.apache.struts:struts2-core (Maven) Vendor— Affected 2.5 to before 2.5.17 Fixed in 2.5.17 Patch available GHSA-cr6j-3jp9-rw65
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:struts:*:*:*:*:*:*:*:* | 2.0.4 to before 2.3.35; 2.5.0 to before 2.5.17 | Vulnerable | Apache |
| cpe:2.3:a:netapp:active_iq_unified_manager:*:*:*:*:*:windows:*:* | 7.3 | Vulnerable | NetApp |
| cpe:2.3:a:netapp:active_iq_unified_manager:*:*:*:*:*:vmware_vsphere:*:* | 9.5 | Vulnerable | NetApp |
| cpe:2.3:a:netapp:oncommand_insight:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | NetApp |
| cpe:2.3:a:netapp:oncommand_workflow_automation:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | NetApp |
| cpe:2.3:a:netapp:snapcenter:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | NetApp |
| cpe:2.3:a:oracle:communications_policy_management:*:*:*:*:*:*:*:* | before 12.5.0 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:enterprise_manager_base_platform:13.3.0.0:*:*:*:*:*:*:* | 13.3.0.0 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:enterprise_manager_base_platform:13.4.0.0:*:*:*:*:*:*:* | 13.4.0.0 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:mysql_enterprise_monitor:*:*:*:*:*:*:*:* | up to 3.4.9.4237; 4.0.0 – 4.0.6.5281; 8.0.0 – 8.0.2.8191 | Vulnerable | Oracle |
- cpe:2.3:a:apache:struts:*:*:*:*:*:*:*:* Versions 2.0.4 to before 2.3.35; 2.5.0 to before 2.5.17 Vulnerable ·Apache
- cpe:2.3:a:netapp:active_iq_unified_manager:*:*:*:*:*:windows:*:* Versions 7.3 Vulnerable ·NetApp
- cpe:2.3:a:netapp:active_iq_unified_manager:*:*:*:*:*:vmware_vsphere:*:* Versions 9.5 Vulnerable ·NetApp
- cpe:2.3:a:netapp:oncommand_insight:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
- cpe:2.3:a:netapp:oncommand_workflow_automation:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
- cpe:2.3:a:netapp:snapcenter:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
- cpe:2.3:a:oracle:communications_policy_management:*:*:*:*:*:*:*:* Versions before 12.5.0 Vulnerable ·Oracle
- cpe:2.3:a:oracle:enterprise_manager_base_platform:13.3.0.0:*:*:*:*:*:*:* Versions 13.3.0.0 Vulnerable ·Oracle
- cpe:2.3:a:oracle:enterprise_manager_base_platform:13.4.0.0:*:*:*:*:*:*:* Versions 13.4.0.0 Vulnerable ·Oracle
- cpe:2.3:a:oracle:mysql_enterprise_monitor:*:*:*:*:*:*:*:* Versions up to 3.4.9.4237; 4.0.0 – 4.0.6.5281; 8.0.0 – 8.0.2.8191 Vulnerable ·Oracle
Remediation
- Fix · GHSA-cr6j-3jp9-rw65 org.apache.struts:struts2-core (Maven) Fixed in 2.3.35 Advisory →
- Fix · GHSA-cr6j-3jp9-rw65 org.apache.struts:struts2-core (Maven) Fixed in 2.5.17 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Critical. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat JBoss Fuse Service Works 6
Timeline
- 2021-11-03 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2018-11776
- 2026-10-03 Alias added: GHSA-cr6j-3jp9-rw65
References
Exploit 5
Patch 3
Advisory 8
- https://www.oracle.com/security-alerts/cpujul2020.html
- https://security.netapp.com/advisory/ntap-20181018-0002/
- https://cwiki.apache.org/confluence/display/WW/S2-057
- https://psirt.global.sonicwall.com/vuln-detail/SNWLID-2018-0012
- https://security.netapp.com/advisory/ntap-20180822-0001/
- http://www.arubanetworks.com/assets/alert/ARUBA-PSA-2018-005.txt
- http://packetstormsecurity.com/files/172830/Apache-Struts-Remote-Code-Execution.html
- https://nvd.nist.gov/vuln/detail/CVE-2018-11776
Other 13
- [announce] 20200131 Apache Software Foundation Security Report: 2019
- https://github.com/apache/struts/commit/6e87474f9ad0549f07dd2c37d50a9ccd0977c6e
- https://www.exploit-db.com/exploits/45367
- https://www.exploit-db.com/exploits/45262
- https://www.exploit-db.com/exploits/45260
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2018-11776
- https://web.archive.org/web/20201208145803/https://securitytracker.com/id/1041547
- https://web.archive.org/web/20200807025819/http://www.securitytracker.com/id/1041888
- https://web.archive.org/web/20180822160726/http://www.securityfocus.com/bid/105125
- https://security.netapp.com/advisory/ntap-20181018-0002
- https://security.netapp.com/advisory/ntap-20180822-0001
- https://lists.apache.org/thread.html/r6d03e45b81eab03580cf7f8bb51cb3e9a1b10a2cc0c6a2d3cc92ed0c@%3Cannounce.apache.org%3E
- https://github.com/apache/struts
More Apache Struts vulnerabilities
- TI-2020-13278 Expression language injection in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-07171 Improper input validation in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2013-02013 Apache Struts 2.0.0 through 2.3.15 allows remote attackers to execute arbitrary OGNL… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-00357 The ExceptionDelegator component in Apache Struts before 2.2.3.1 interprets parameter… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-07185 Deserialization of untrusted data in Apache Struts KEVCVSS 3.1HIGH 8.1
Sources
- CVE-2018-11776 · CVE Program
- CVE-2018-11776 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- GHSA-cr6j-3jp9-rw65 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-11776 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences