Buffer overflow in OPC UA applications allows remote attackers to trigger a stack…
Priority MEDIUM 46CWE-787Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-787 and the CVSS impact.
Summary
Buffer overflow in OPC UA applications allows remote attackers to trigger a stack overflow with carefully structured requests.
Why it matters now
EPSS 0.11809 96th percentileScored 2026-11-07
Fix Fixed OPCFoundation.NetStandard.Opc.Ua (NuGet): 1.4.353.15
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | OPCFoundation.NetStandard.Opc.Ua (NuGet) | before 1.4.353.15 | 1.4.353.15 | Patch available | GHSA-782p-53wq-cxmj |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- OPCFoundation.NetStandard.Opc.Ua (NuGet) Vendor— Affected before 1.4.353.15 Fixed in 1.4.353.15 Patch available GHSA-782p-53wq-cxmj
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:opcfoundation:unified_architecture-.net-legacy:*:*:*:*:*:*:*:* | up to 1.03.342 | Vulnerable | OPC Foundation |
| cpe:2.3:a:opcfoundation:unified_architecture-java:*:*:*:*:*:*:*:* | up to 1.03.343 | Vulnerable | OPC Foundation |
| cpe:2.3:a:opcfoundation:unified_architecture_.net-standard:*:*:*:*:*:*:*:* | up to 1.03.352.12 | Vulnerable | OPC Foundation |
| cpe:2.3:a:opcfoundation:unified_architecture_ansic:*:*:*:*:*:*:*:* | up to 1.03.340 | Vulnerable | OPC Foundation |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:opcfoundation:unified_architecture-.net-legacy:*:*:*:*:*:*:*:* Versions up to 1.03.342 Vulnerable ·OPC Foundation
- cpe:2.3:a:opcfoundation:unified_architecture-java:*:*:*:*:*:*:*:* Versions up to 1.03.343 Vulnerable ·OPC Foundation
- cpe:2.3:a:opcfoundation:unified_architecture_.net-standard:*:*:*:*:*:*:*:* Versions up to 1.03.352.12 Vulnerable ·OPC Foundation
- cpe:2.3:a:opcfoundation:unified_architecture_ansic:*:*:*:*:*:*:*:* Versions up to 1.03.340 Vulnerable ·OPC Foundation
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-782p-53wq-cxmj OPCFoundation.NetStandard.Opc.Ua (NuGet) Fixed in 1.4.353.15 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2018-12086
- 2026-10-03 Alias added: GHSA-782p-53wq-cxmj
References
Sources
- CVE-2018-12086 · CVE Program
- CVE-2018-12086 · NVD
- FIRST EPSS
- GHSA-782p-53wq-cxmj · GitHub Advisory Database · CC BY 4.0
- CVE-2018-12086 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences