Smarty_Security::isTrustedResourceDir() in Smarty before 3.1.33 is prone to a path…
Priority LOW 39CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
Smarty_Security::isTrustedResourceDir() in Smarty before 3.1.33 is prone to a path traversal vulnerability due to insufficient template code sanitization. This allows attackers controlling the executed template code to bypass the trusted directory security restriction and read arbitrary files.
Why it matters now
EPSS 0.03463 89th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed smarty/smarty (Packagist): 3.1.33
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | smarty/smarty (Packagist) | before 3.1.33 | 3.1.33 | Patch available | GHSA-7gfx-wxfh-7rvm |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- smarty/smarty (Packagist) Vendor— Affected before 3.1.33 Fixed in 3.1.33 Patch available GHSA-7gfx-wxfh-7rvm
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:smarty:smarty:*:*:*:*:*:*:*:* | before 3.1.33 | Vulnerable | smarty-php |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:smarty:smarty:*:*:*:*:*:*:*:* Versions before 3.1.33 Vulnerable ·smarty-php
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-7gfx-wxfh-7rvm smarty/smarty (Packagist) Fixed in 3.1.33 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2018-13982
- 2026-10-03 Alias added: GHSA-7gfx-wxfh-7rvm
References
Exploit 1
Patch 5
- https://github.com/smarty-php/smarty/commit/2e081a51b1effddb23f87952959139ac62654d50
- https://github.com/smarty-php/smarty/commit/f9ca3c63d1250bb56b2bda609dcc9dd81f0065f8
- https://github.com/smarty-php/smarty/commit/c9dbe1d08c081912d02bd851d1d1b6388f6133d1
- https://github.com/smarty-php/smarty/commit/8d21f38dc35c4cd6b31c2f23fc9b8e5adbc56dfe
- https://github.com/smarty-php/smarty/commit/bcedfd6b58bed4a7366336979ebaa5a240581531
Advisory 4
Sources
- CVE-2018-13982 · CVE Program
- CVE-2018-13982 · NVD
- FIRST EPSS
- GHSA-7gfx-wxfh-7rvm · GitHub Advisory Database · CC BY 4.0
- CVE-2018-13982 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences