Pagekit before 1.0.14 has a /user/login?redirect= open redirect vulnerability.
Priority LOW 29CWE-601Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-601.
Summary
Pagekit before 1.0.14 has a /user/login?redirect= open redirect vulnerability.
Why it matters now
EPSS 0.00957 61st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed pagekit/pagekit (Packagist): 1.0.14
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | pagekit/pagekit (Packagist) | before 1.0.14 | 1.0.14 | Patch available | GHSA-v47j-rw9h-6m47 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- pagekit/pagekit (Packagist) Vendor— Affected before 1.0.14 Fixed in 1.0.14 Patch available GHSA-v47j-rw9h-6m47
Remediation
- Fix · GHSA-v47j-rw9h-6m47 pagekit/pagekit (Packagist) Fixed in 1.0.14 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-14381
- 2026-10-03 Alias added: GHSA-v47j-rw9h-6m47
References
More Pagekit vulnerabilities
- TI-2025-41149 An Insecure Direct Object Reference (IDOR) in Pagekit CMS v1.0.18 allows attackers to escalate privileges. CVSS 3.1CRITICAL 9.8
- TI-2025-41148 An authenticated arbitrary file upload vulnerability in the /storage/poc.php component of… CVSS 3.1CRITICAL 9.9
- TI-2022-18350 A file upload vulnerability exists in the storage feature of pagekit 1.0.18, which allows… CVSS 3.1CRITICAL 9.8
- TI-2023-21646 An issue in Pagekit pagekit v.1.0.18 alows a remote attacker to execute arbitrary code… CVSS 3.1HIGH 7.8
- TI-2024-30850 Pagekit 1.0.18 is vulnerable to Cross Site Scripting (XSS) in index.php/admin/site/widget. CVSS 3.1MEDIUM 4.7
- TI-2021-19838 pagekit all versions, as of 15-10-2021, is vulnerable to SQL Injection via Comment listing. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2018-14381 · CVE Program
- CVE-2018-14381 · NVD
- FIRST EPSS
- GHSA-v47j-rw9h-6m47 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences