A NULL pointer dereference vulnerability exists in the xpath.c:xmlXPathCompOpEval()…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 16 fixed, 3 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-476.
Summary
A NULL pointer dereference vulnerability exists in the xpath.c:xmlXPathCompOpEval() function of libxml2 through 2.9.8 when parsing an invalid XPath expression in the XPATH_OP_AND or XPATH_OP_OR case. Applications processing untrusted XSL format inputs with the use of the libxml2 library may be vulnerable to a denial of service attack due to a crash of the application.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | nokogiri (RubyGems) | before 1.8.5 | 1.8.5 | Patch available | GHSA-6qvp-r6r3-9p7h |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- nokogiri (RubyGems) Vendor— Affected before 1.8.5 Fixed in 1.8.5 Patch available GHSA-6qvp-r6r3-9p7h
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:esm:*:*:* | 12.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* | 16.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* | 18.04 | Vulnerable | Canonical |
| cpe:2.3:o:debian:debian_linux:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | Debian |
| cpe:2.3:a:xmlsoft:libxml2:*:*:*:*:*:*:*:* | up to 2.9.8 | Vulnerable | xmlsoft |
- cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:esm:*:*:* Versions 12.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* Versions 16.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
- cpe:2.3:o:debian:debian_linux:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·Debian
- cpe:2.3:a:xmlsoft:libxml2:*:*:*:*:*:*:*:* Versions up to 2.9.8 Vulnerable ·xmlsoft
Remediation
- Fix · GHSA-6qvp-r6r3-9p7h nokogiri (RubyGems) Fixed in 1.8.5 Advisory →
Red Hat 3 advisories
- RHSA-2020:1827 Released 2020-04-28 · Red Hat rating Moderatelibxml2 security update
- Red Hat Enterprise Linux AppStream (v. 8) libxml2-devel-2.9.7-7.el8
- Red Hat Enterprise Linux BaseOS (v. 8) libxml2-2.9.7-7.el8, python3-libxml2-2.9.7-7.el8
- RHSA-2020:1190 Released 2020-03-31 · Red Hat rating Moderatelibxml2 security update
- Red Hat Enterprise Linux Client (v. 7) libxml2-2.9.1-6.el7.4, libxml2-python-2.9.1-6.el7.4
- Red Hat Enterprise Linux Client Optional (v. 7) libxml2-devel-2.9.1-6.el7.4, libxml2-static-2.9.1-6.el7.4
- Red Hat Enterprise Linux ComputeNode (v. 7) libxml2-2.9.1-6.el7.4, libxml2-python-2.9.1-6.el7.4
- Red Hat Enterprise Linux ComputeNode Optional (v. 7) libxml2-devel-2.9.1-6.el7.4, libxml2-static-2.9.1-6.el7.4
- Red Hat Enterprise Linux Server (v. 7) libxml2-2.9.1-6.el7.4, libxml2-2.9.1-6.el7.4.ppc, libxml2-devel-2.9.1-6.el7.4 +2
- Red Hat Enterprise Linux Server Optional (v. 7) libxml2-static-2.9.1-6.el7.4, libxml2-static-2.9.1-6.el7.4.ppc
- Red Hat Enterprise Linux Workstation (v. 7) libxml2-2.9.1-6.el7.4, libxml2-devel-2.9.1-6.el7.4, libxml2-python-2.9.1-6.el7.4
- Red Hat Enterprise Linux Workstation Optional (v. 7) libxml2-static-2.9.1-6.el7.4
- RHSA-2019:1543 Released 2019-06-18 · Red Hat rating ImportantRed Hat JBoss Core Services Apache HTTP Server 2.4.29 SP2 security update
- JBoss Core Services Apache HTTP Server 2.4.29 SP2
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 5 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Will not fix |
| JBoss Core Services Apache HTTP Server 2.4.29 SP2 | Fixed | RHSA-2019:1543 |
| RHEL 7-based RHEV-H for RHEV 4 (build requirements) | Fixed | — |
| Red Hat Ansible Tower 3.5 for RHEL 7 Server | Fixed | — |
| Red Hat Ansible Tower 3.6 for RHEL 7 | Fixed | — |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2020:1827 |
| Red Hat Enterprise Linux BaseOS (v. 8) | Fixed | RHSA-2020:1827 |
| Red Hat Enterprise Linux Client (v. 7) | Fixed | RHSA-2020:1190 |
| Red Hat Enterprise Linux Client Optional (v. 7) | Fixed | RHSA-2020:1190 |
| Red Hat Enterprise Linux ComputeNode (v. 7) | Fixed | RHSA-2020:1190 |
| Red Hat Enterprise Linux ComputeNode Optional (v. 7) | Fixed | RHSA-2020:1190 |
| Red Hat Enterprise Linux Server (v. 7) | Fixed | RHSA-2020:1190 |
| Red Hat Enterprise Linux Server Optional (v. 7) | Fixed | RHSA-2020:1190 |
| Red Hat Enterprise Linux Workstation (v. 7) | Fixed | RHSA-2020:1190 |
| Red Hat Enterprise Linux Workstation Optional (v. 7) | Fixed | RHSA-2020:1190 |
| Red Hat Virtualization 4 Hypervisor for RHEL 7 | Fixed | — |
| Red Hat Virtualization 4 Management Agent for RHEL 7 Hosts | Fixed | — |
Not affected: 1 product
- Red Hat JBoss Web Server 3
Timeline
- 2026-10-02 Threatist record created from CVE-2018-14404
- 2026-10-03 Alias added: GHSA-6qvp-r6r3-9p7h
References
Advisory 7
Other 8
- [debian-lts-announce] 20180927 [SECURITY] [DLA 1524-1] libxml2 security update
- https://security.netapp.com/advisory/ntap-20190719-0002/
- [debian-lts-announce] 20200909 [SECURITY] [DLA 2369-1] libxml2 security update
- https://github.com/sparklemotion/nokogiri/issues/1785
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/nokogiri/CVE-2018-14404.yml
- https://security.netapp.com/advisory/ntap-20190719-0002
- https://usn.ubuntu.com/3739-1
- https://usn.ubuntu.com/3739-2
Sources
- CVE-2018-14404 · CVE Program
- CVE-2018-14404 · NVD
- FIRST EPSS
- GHSA-6qvp-r6r3-9p7h · GitHub Advisory Database · CC BY 4.0
- CVE-2018-14404 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences