An SSRF vulnerability in webhooks in Gitea through 1.5.0-rc2 and Gogs through 0.11.53…
Priority MEDIUM 41CWE-918Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-918 and the CVSS impact.
Summary
An SSRF vulnerability in webhooks in Gitea through 1.5.0-rc2 and Gogs through 0.11.53 allows remote attackers to access intranet services.
Why it matters now
EPSS 0.02121 81st percentileScored 2026-11-07
Fix Fixed code.gitea.io/gitea (Go): 1.16.0-rc1gogs.io/gogs (Go): 0.12.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | code.gitea.io/gitea (Go) | before 1.16.0-rc1 | 1.16.0-rc1 | Patch available | GHSA-fg3x-rwq9-74cw |
| — | gogs.io/gogs (Go) | before 0.12.0 | 0.12.0 | Patch available | GHSA-fg3x-rwq9-74cw |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- code.gitea.io/gitea (Go) Vendor— Affected before 1.16.0-rc1 Fixed in 1.16.0-rc1 Patch available GHSA-fg3x-rwq9-74cw
- gogs.io/gogs (Go) Vendor— Affected before 0.12.0 Fixed in 0.12.0 Patch available GHSA-fg3x-rwq9-74cw
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitea:gitea:*:*:*:*:*:*:*:* | before 1.5.0 | Vulnerable | Gitea |
| cpe:2.3:a:gitea:gitea:1.5.0:rc1:*:*:*:*:*:* | 1.5.0 rc1 | Vulnerable | Gitea |
| cpe:2.3:a:gitea:gitea:1.5.0:rc2:*:*:*:*:*:* | 1.5.0 rc2 | Vulnerable | Gitea |
| cpe:2.3:a:gogs:gogs:*:*:*:*:*:*:*:* | up to 0.11.53 | Vulnerable | Gogs |
- cpe:2.3:a:gitea:gitea:*:*:*:*:*:*:*:* Versions before 1.5.0 Vulnerable ·Gitea
- cpe:2.3:a:gitea:gitea:1.5.0:rc1:*:*:*:*:*:* Versions 1.5.0 rc1 Vulnerable ·Gitea
- cpe:2.3:a:gitea:gitea:1.5.0:rc2:*:*:*:*:*:* Versions 1.5.0 rc2 Vulnerable ·Gitea
- cpe:2.3:a:gogs:gogs:*:*:*:*:*:*:*:* Versions up to 0.11.53 Vulnerable ·Gogs
Remediation
- Fix · GHSA-fg3x-rwq9-74cw code.gitea.io/gitea (Go) Fixed in 1.16.0-rc1 Advisory →
- Fix · GHSA-fg3x-rwq9-74cw gogs.io/gogs (Go) Fixed in 0.12.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-15192
- 2026-10-03 Alias added: GHSA-fg3x-rwq9-74cw
References
Advisory 3
Sources
- CVE-2018-15192 · CVE Program
- CVE-2018-15192 · NVD
- FIRST EPSS
- GHSA-fg3x-rwq9-74cw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences