Command injection in libnmap
Priority MEDIUM 49CWE-77Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-77.
Summary
A command injection vulnerability in libnmapp package for versions <0.4.16 allows arbitrary commands to be executed via arguments to the range options.
Why it matters now
EPSS 0.03854 90th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed libnmap (npm): 0.4.16
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | libnmap | 0.4.16 | — | No fix listed | CNA |
| — | libnmap (npm) | before 0.4.16 | 0.4.16 | Patch available | GHSA-7g2w-6r25-2j7p |
- libnmap Vendor— Affected 0.4.16 Fixed in — No fix listed CNA
- libnmap (npm) Vendor— Affected before 0.4.16 Fixed in 0.4.16 Patch available GHSA-7g2w-6r25-2j7p
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:libnmap_project:libnmap:*:*:*:*:*:node.js:*:* | before 0.4.16 | Vulnerable | Libnmap Project |
- cpe:2.3:a:libnmap_project:libnmap:*:*:*:*:*:node.js:*:* Versions before 0.4.16 Vulnerable ·Libnmap Project
Remediation
- Fix · GHSA-7g2w-6r25-2j7p libnmap (npm) Fixed in 0.4.16 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-16461
- 2026-10-03 Alias added: GHSA-7g2w-6r25-2j7p
- 2026-10-16 EPSS moved to the 90th–95th percentile
References
Sources
- CVE-2018-16461 · CVE Program
- CVE-2018-16461 · NVD
- FIRST EPSS
- GHSA-7g2w-6r25-2j7p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences