Cross-site scripting in Loofah
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
In the Loofah gem for Ruby, through v2.2.2, unsanitized JavaScript may occur in sanitized output when a crafted SVG element is republished.
Why it matters now
EPSS 0.00916 60th percentileScored 2026-11-07
Fix Partial loofah (RubyGems): 2.2.3Red Hat: 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Loofah (Ruby Gem) | v2.2.3 | — | No fix listed | CNA |
| — | loofah (RubyGems) | before 2.2.3 | 2.2.3 | Patch available | GHSA-g4xq-jx4w-4cjv |
- Loofah (Ruby Gem) Vendor— Affected v2.2.3 Fixed in — No fix listed CNA
- loofah (RubyGems) Vendor— Affected before 2.2.3 Fixed in 2.2.3 Patch available GHSA-g4xq-jx4w-4cjv
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:loofah_project:loofah:*:*:*:*:*:ruby:*:* | up to 2.2.2 | Vulnerable | flavorjones |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:loofah_project:loofah:*:*:*:*:*:ruby:*:* Versions up to 2.2.2 Vulnerable ·flavorjones
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-g4xq-jx4w-4cjv loofah (RubyGems) Fixed in 2.2.3 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Satellite 6 | Affected | No fix planned: Will not fix |
| Red Hat Software Collections | Affected | No fix planned: Will not fix |
Not affected: 1 product
- CloudForms Management Engine 5
Timeline
- 2026-10-02 Threatist record created from CVE-2018-16468
- 2026-10-03 Alias added: GHSA-g4xq-jx4w-4cjv
References
Sources
- CVE-2018-16468 · CVE Program
- CVE-2018-16468 · NVD
- FIRST EPSS
- GHSA-g4xq-jx4w-4cjv · GitHub Advisory Database · CC BY 4.0
- CVE-2018-16468 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences