Authentication bypass by spoofing in HackerOne express-cart
Priority MEDIUM 40CWE-290Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-290.
Summary
A deficiency in the access control in module express-cart <=1.1.5 allows unprivileged users to add new users to the application as administrators.
Why it matters now
EPSS 0.01156 67th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed express-cart (npm): 1.1.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | express-cart | >=1.1.6 | — | No fix listed | CNA |
| — | express-cart (npm) | before 1.1.6 | 1.1.6 | Patch available | GHSA-wj36-v8j4-pc7c |
- express-cart VendorHackerOne Affected >=1.1.6 Fixed in — No fix listed CNA
- express-cart (npm) Vendor— Affected before 1.1.6 Fixed in 1.1.6 Patch available GHSA-wj36-v8j4-pc7c
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:express-cart_project:express-cart:*:*:*:*:*:node.js:*:* | up to 1.1.5 | Vulnerable | Express-cart Project |
- cpe:2.3:a:express-cart_project:express-cart:*:*:*:*:*:node.js:*:* Versions up to 1.1.5 Vulnerable ·Express-cart Project
Remediation
- Fix · GHSA-wj36-v8j4-pc7c express-cart (npm) Fixed in 1.1.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-16483
- 2026-10-03 Alias added: GHSA-wj36-v8j4-pc7c
References
More Express-cart Project Express-cart vulnerabilities
- TI-2018-02754 Path traversal in HackerOne express-cart CVSS 3.1HIGH 8.8
- TI-2020-14335 Cross Site Request Forgery (CSRF) vulnerability in Express cart v1.1.16 allows attackers… CVSS 3.1HIGH 8.8
- TI-2021-12245 The express-cart package through 1.1.10 for Node.js allows Reflected XSS (for an admin)… CVSS 3.1MEDIUM 4.8
Sources
- CVE-2018-16483 · CVE Program
- CVE-2018-16483 · NVD
- FIRST EPSS
- GHSA-wj36-v8j4-pc7c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences