Ansible "User" module leaks any data which is passed on as a parameter to ssh-keygen.
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 6 fixed, 4 without a fix
Attack profile from CVSS 3.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-311.
Summary
Ansible "User" module leaks any data which is passed on as a parameter to ssh-keygen. This could lean in undesirable situations such as passphrases credentials passed as a parameter for the ssh-keygen executable. Showing those credentials in clear text form for every user which have access just to the process list.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| [UNKNOWN] | Ansible | all versions | — | No fix listed | CNA |
| — | ansible (PyPI) | 2.7.0a1 to before 2.7.1 | 2.7.1 | Patch available | GHSA-hwrm-63v2-42g4 |
| — | ansible (PyPI) | 2.6.0a1 to before 2.6.7 | 2.6.7 | Patch available | GHSA-hwrm-63v2-42g4 |
| — | ansible (PyPI) | before 2.5.11 | 2.5.11 | Patch available | GHSA-hwrm-63v2-42g4 |
- Ansible Vendor[UNKNOWN] Affected all versions Fixed in — No fix listed CNA
- ansible (PyPI) Vendor— Affected 2.7.0a1 to before 2.7.1 Fixed in 2.7.1 Patch available GHSA-hwrm-63v2-42g4
- ansible (PyPI) Vendor— Affected 2.6.0a1 to before 2.6.7 Fixed in 2.6.7 Patch available GHSA-hwrm-63v2-42g4
- ansible (PyPI) Vendor— Affected before 2.5.11 Fixed in 2.5.11 Patch available GHSA-hwrm-63v2-42g4
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:redhat:ansible_engine:2.0:*:*:*:*:*:*:* | 2.0 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:ansible_engine:2.5:*:*:*:*:*:*:* | 2.5 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:ansible_engine:2.6:*:*:*:*:*:*:* | 2.6 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:ansible_engine:2.7:*:*:*:*:*:*:* | 2.7 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:ansible_tower:3.3.0:*:*:*:*:*:*:* | 3.3.0 | Vulnerable | Red Hat |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:a:suse:package_hub:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | SUSE |
| cpe:2.3:o:suse:linux_enterprise:12.0:*:*:*:*:*:*:* | 12.0 | Running on | SUSE |
- cpe:2.3:a:redhat:ansible_engine:2.0:*:*:*:*:*:*:* Versions 2.0 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:ansible_engine:2.5:*:*:*:*:*:*:* Versions 2.5 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:ansible_engine:2.6:*:*:*:*:*:*:* Versions 2.6 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:ansible_engine:2.7:*:*:*:*:*:*:* Versions 2.7 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:ansible_tower:3.3.0:*:*:*:*:*:*:* Versions 3.3.0 Vulnerable ·Red Hat
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:a:suse:package_hub:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·SUSE
- cpe:2.3:o:suse:linux_enterprise:12.0:*:*:*:*:*:*:* Versions 12.0 Running on ·SUSE
Remediation
- Fix · GHSA-hwrm-63v2-42g4 ansible (PyPI) Fixed in 2.7.1 Advisory →
- Fix · GHSA-hwrm-63v2-42g4 ansible (PyPI) Fixed in 2.6.7 Advisory →
- Fix · GHSA-hwrm-63v2-42g4 ansible (PyPI) Fixed in 2.5.11 Advisory →
Red Hat 6 advisories
- RHSA-2019:0590 Released 2019-03-18 · Red Hat rating Lowansible security and bug fix update
- Red Hat OpenStack Platform 14.0 ansible-2.6.11-1.el7ae
- RHSA-2019:0564 Released 2019-03-14 · Red Hat rating LowRed Hat Enterprise Linux OpenStack Platform security update
- Red Hat OpenStack Platform 13.0 ansible-2.6.11-1.el7ae, openstack-ec2-api-6.0.1-0.20181123223255.1e25260.el7ost, openstack-manila-1:6.0.2-5.el7ost +26
- RHSA-2018:3462 Released 2018-11-05 · Red Hat rating Moderate[ansible] security and bug fix update
- Red Hat Ansible Engine 2 for RHEL 7 ansible-2.7.1-1.el7ae
Show 3 more Red Hat advisories
- RHSA-2018:3461 Released 2018-11-05 · Red Hat rating Moderate[ansible] security update
- Red Hat Ansible Engine 2.5 for RHEL 7 Server ansible-2.5.11-1.el7ae, ansible-doc-2.5.11-1.el7ae
- RHSA-2018:3463 Released 2018-11-05 · Red Hat rating Moderate[ansible] security and bug fix update
- Red Hat Ansible Engine 2.7 for RHEL 7 Server ansible-2.7.1-1.el7ae
- RHSA-2018:3460 Released 2018-11-05 · Red Hat rating Moderate[ansible] security update
- Red Hat Ansible Engine 2.6 for RHEL 7 Server ansible-2.6.7-1.el7ae
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ceph Storage 2 | Affected | No fix planned: Out of support scope |
| Red Hat Ceph Storage 3 | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 10 (Newton) | Affected | No fix planned: Will not fix |
| Red Hat Storage 3 | Affected | No fix planned: Will not fix |
| Red Hat Ansible Engine 2 for RHEL 7 | Fixed | RHSA-2018:3462 |
| Red Hat Ansible Engine 2.5 for RHEL 7 Server | Fixed | RHSA-2018:3461 |
| Red Hat Ansible Engine 2.6 for RHEL 7 Server | Fixed | RHSA-2018:3460 |
| Red Hat Ansible Engine 2.7 for RHEL 7 Server | Fixed | RHSA-2018:3463 |
| Red Hat OpenStack Platform 13.0 | Fixed | RHSA-2019:0564 |
| Red Hat OpenStack Platform 14.0 | Fixed | RHSA-2019:0590 |
Timeline
- 2026-10-02 Threatist record created from CVE-2018-16837
- 2026-10-03 Alias added: GHSA-hwrm-63v2-42g4
References
Advisory 14
- RHSA-2018:3460
- RHSA-2018:3462
- RHSA-2018:3505
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16837
- RHSA-2018:3463
- [debian-lts-announce] 20181112 [SECURITY] [DLA 1576-1] ansible security update
- RHSA-2018:3461
- DSA-4396
- openSUSE-SU-2019:1125
- openSUSE-SU-2019:1635
- USN-4072-1
- openSUSE-SU-2019:1858
- https://nvd.nist.gov/vuln/detail/CVE-2018-16837
- https://access.redhat.com/security/cve/cve-2018-16837
Other 12
- https://github.com/ansible/ansible/pull/47487
- https://github.com/ansible/ansible/pull/47486
- https://github.com/ansible/ansible/pull/47445
- https://github.com/ansible/ansible/pull/47436
- https://github.com/ansible/ansible/commit/77928e6c3a2ad878b20312ce5d74d9d7741e0df0
- https://github.com/ansible/ansible/commit/b618339c321c387230d3ea523e80ad47af3de5cf
- https://github.com/ansible/ansible/commit/f50cc0b8cb399bb7b7c1ad23b94c9404f0cc6d23
- https://web.archive.org/web/20200227105539/http://www.securityfocus.com/bid/105700
- https://usn.ubuntu.com/4072-1
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2018-44.yaml
- https://github.com/ansible/ansible/blob/c963ef1dfbf73efea5106624eb48b346f01eaefd/changelogs/CHANGELOG-v2.7.rst?plain=1#L138
- https://github.com/ansible/ansible
Sources
- CVE-2018-16837 · CVE Program
- CVE-2018-16837 · NVD
- FIRST EPSS
- GHSA-hwrm-63v2-42g4 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-16837 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences